Bug 345 - MonoDevelop 2.8a1 MD Getting Exception when code syncs with Xcode
Summary: MonoDevelop 2.8a1 MD Getting Exception when code syncs with Xcode
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2011-08-19 20:51 UTC by Alex Soto
Modified: 2011-08-26 11:36 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alex Soto 2011-08-19 20:51:22 UTC
I'm getting the following exception each time MonoDevelop tries to sync code with Xcode this happened after installing Xcode 4.2 Beta 6

System.Exception: Error ScriptError: Xcode got an error: Connection is invalid.
  at MonoDevelop.MacInterop.AppleScript.Run (Boolean compile, MonoDevelop.MacInterop.AEDesc& scriptData) [0x00012] in /sources/monodevelop/main/src/addins/MacPlatform/MacInterop/AppleScript.cs:107 
  at MonoDevelop.MacInterop.AppleScript.Run (System.String scriptSource) [0x00010] in /sources/monodevelop/main/src/addins/MacPlatform/MacInterop/AppleScript.cs:83 
  at MonoDevelop.MacInterop.AppleScript.Run (System.String scriptSourceFormat, System.Object[] args) [0x00000] in /sources/monodevelop/main/src/addins/MacPlatform/MacInterop/AppleScript.cs:74 
  at MonoDevelop.MacDev.XcodeSyncing.XcodeMonitor.IsProjectOpen () [0x0000d] in /sources/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeMonitor.cs:303 
  at MonoDevelop.MacDev.XcodeSyncing.XcodeProjectTracker.AppRegainedFocus (System.Object sender, System.EventArgs e) [0x0000c] in /sources/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeProjectTracker.cs:119 
  at (wrapper delegate-invoke) <Module>:invoke_void__this___object_EventArgs (object,System.EventArgs)
  at MonoDevelop.Components.Commands.CommandManager.UpdateAppFocusStatus (Boolean hasFocus, Boolean lastFocusedExists) [0x0006f] in /sources/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Commands/CommandManager.cs:1268 
  at MonoDevelop.Components.Commands.CommandManager.GetActiveWindow (Gtk.Window win) [0x00097] in /sources/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Commands/CommandManager.cs:1091 
  at MonoDevelop.Components.Commands.CommandManager.GetActiveWidget (Gtk.Window win) [0x00000] in /sources/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Commands/CommandManager.cs:1103 
  at MonoDevelop.Components.Commands.CommandManager.UpdateToolbars () [0x0000c] in /sources/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Commands/CommandManager.cs:1243 
  at MonoDevelop.Components.Commands.CommandManager.UpdateStatus () [0x00016] in /sources/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Commands/CommandManager.cs:1121 
  at GLib.Timeout+TimeoutProxy.Handler () [0x00000] in <filename unknown>:0
Comment 1 Alan McGovern 2011-08-24 06:57:11 UTC
I have the same xcode version and can't reproduce the issue. Can you tell me exactly the steps you follow to get the error and also the version of MonoDevelop and MonoTouch that you're using?
Comment 2 Alan McGovern 2011-08-24 09:24:38 UTC
By any chance do you get this exception when XCode crashes? The only time I managed to get this exception was when XCode crashed on startup. Right now my suspicion is that if XCode crashes at just the wrong moment, MonoDevelop will get this error and report it.
Comment 3 Alex Soto 2011-08-26 11:34:10 UTC
yest that happened when xcode crashed :) also Xcode has been a little crashy  in this betas, im on Beta 6
Comment 4 Alan McGovern 2011-08-26 11:36:04 UTC
Perfect. I've added some extra error handling so when Xcode does crash like this, you'll get a slightly more useful error message. When Xcode stops crashing at the drop of a hat this issue will vanish completely ;)

Marking this as resolved, thanks for the report!