Bug 34457 - Russian text not displaying correctly
Summary: Russian text not displaying correctly
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-30 14:32 UTC by Cody Beyer (MSFT)
Modified: 2015-10-15 07:50 UTC (History)
5 users (show)

Tags: BZSRC5SR4S2_C5SR4S1
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Cody Beyer (MSFT) 2015-09-30 14:32:43 UTC
### Description

The following sample attempts to write Russian text to Application Output using Console.WriteLine The text is not displayed correctly when this is called. 

One quick item of note, the same code running in a pure Console app does work correctly. 

### Sample

https://www.dropbox.com/s/7mkis6q8n5300uj/RussianCharTest.zip?dl=0

### Steps to Reproduce

1. Download sample
2. Open in Xamarin Studio
3. Tap button

### Expected Results

The string "тест" should display in Application Output

### Actual Results

—Ç–µ—Å—Ç is displayed

### Versions

=== Xamarin Studio ===

Version 5.9.7 (build 9)
Installation UUID: fe69ddf8-5edc-42a6-ac7a-fe710eb02c0e
Runtime:
	Mono 4.0.4 ((detached/d481017)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400040004

=== Xamarin.Android ===

Version: 5.1.6.7 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 7.0.1 (8228)
Build 7A1001

=== Xamarin.iOS ===

Version: 9.0.1.20 (Business Edition)
Hash: d8e9592
Branch: master
Build date: 2015-09-18 23:22:05-0400

=== Xamarin.Mac ===

Version: 2.0.2.111 (Business Edition)

=== Build Information ===

Release ID: 509070009
Git revision: 31fa64709030b3edb971237780a452a4c69943c4
Build date: 2015-09-17 11:44:37-04
Xamarin addins: b105d33d8cd72911ff2cf3ee0b7715d37e5f19a6

=== Operating System ===

Mac OS X 10.11.0
Darwin Codys-MacBook-Pro.local 15.0.0 Darwin Kernel Version 15.0.0
    Wed Aug 26 16:57:32 PDT 2015
    root:xnu-3247.1.106~1/RELEASE_X86_64 x86_64
Comment 1 Sebastien Pouliot 2015-09-30 15:09:04 UTC
Text sent to the console is displayed with `NSLog` to the Application Output. IIRC there was a bug in iOS9 with it and it's possible that the workaround is messing with some string encoding. I'll check that (and see if it's still required in the case it's still present).
Comment 2 Sebastien Pouliot 2015-09-30 17:32:27 UTC
Removing the workaround fix the issue (and it seems fixed in iOS final builds).

maccore/master aed543f00df89036aac387fe335f3d7c28b7a54d
Comment 4 Shruti 2015-10-15 07:50:27 UTC
First I have reproduced this issue with latest C6 builds and observed that this in application output text '—Ç–µ—Å—Ç' is displaying instead of "Tect".
C6 Build monotouch-9.2.0.93_1a6b88f2b2305d50bad065ae4c7292ab6348ff60
Screencast: http://www.screencast.com/t/3aBY3xKra

Verified this issue on master monotouch-9.3.0.147_03b93e71acd019f362d67f053697557f9b7fa175 and observed that now application output text is displaying as 'Tect'.
Screencast: http://www.screencast.com/t/dMm0HUCD