Bug 3442 - MonoDevelop should warn if breakpoints are set in code with no symbols
Summary: MonoDevelop should warn if breakpoints are set in code with no symbols
Status: RESOLVED NORESPONSE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: Trunk
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-02-14 09:44 UTC by Alan McGovern
Modified: 2013-12-05 18:34 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Alan McGovern 2012-02-14 09:44:43 UTC
Currently if i set breakpoints in some source files and the resulting mdb is not generated, monodevelop will silently ignore those breakpoints. It'd be great if it instead displayed a visual warning saying:

"Hey, these breakpoints [list of breakpoints] could not be set as there is no debugging information. The debugger will not be able to halt execution during this session."

Or similar
Comment 1 Mikayla Hutchinson [MSFT] 2012-02-14 10:12:16 UTC
It's actually silent? It doesn't even print the "Could not insert breakpoint" message or dim the breakpoint to indicate its state?
Comment 2 PJ 2013-11-19 17:04:06 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 3 PJ 2013-12-05 18:34:08 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.