Bug 34384 - Signing impossible since last update
Summary: Signing impossible since last update
Status: CLOSED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 9.0 (iOS9)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-29 05:43 UTC by Geoffrey
Modified: 2015-09-30 04:51 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED ANSWERED

Description Geoffrey 2015-09-29 05:43:18 UTC
Hello,
First, Sorry for my little English ...

I Have Xamarin Studio 5.9.7 (business license) on a Mac Yosemite 10.10.5.
I have updated last IOS SDK 9.0 and XCode 7.0 since I can't signing my application on Ad-Hoc build :
One error : Code Signing failed .

In output build, i've this :

Signing application
codesign -v --force --sign "5D38E746BCC13E61608641CC3EACB6D547575AC0" --entitlements "/Users/winlog/Documents/WINLOG/Tiamp/Engine/Mainline/Src/WinLog.Mobile.Application/WinLog.Mobile.Application.IOS/TiampTouchIpad/bin/iPhone/Debug/TiampTouchIpad.xcent" "/Users/winlog/Documents/WINLOG/Tiamp/Engine/Mainline/Src/WinLog.Mobile.Application/WinLog.Mobile.Application.IOS/TiampTouchIpad/bin/iPhone/Debug/TiampTouchIpad.app"
/Users/winlog/Documents/WINLOG/Tiamp/Engine/Mainline/Src/WinLog.Mobile.Application/WinLog.Mobile.Application.IOS/TiampTouchIpad/bin/iPhone/Debug/TiampTouchIpad.app: invalid resource specification rule(s)
codesign exited with code 1

On Xamarin's forum I see many developper have the same problem...
https://forums.xamarin.com/discussion/51070/updated-to-xcode-7-and-sdk-9-0

Can you help us please ?

Thx 
Geoffrey
Comment 1 Sebastien Pouliot 2015-09-29 08:13:43 UTC
It will be fixed in newer versions of Xamarin Studio 5.9.7.20+

Possible workaround:

Enable "Project Options -> General -> Use MSBuild build engine (unsupported for
this project type)" and clean and rebuild the project.

*** This bug has been marked as a duplicate of bug 31424 ***
Comment 2 Geoffrey 2015-09-29 08:28:53 UTC
I've downloaded the latest version of Xamarin Studio 5.9.7 (build 9).

I see the possible workaround on forum but it does'nt work for me, mono's references are lost ... i don't understand why ... 

for duplicate, i'm not allowed to see bug 31424...

How to download XS5.9.7.20 ?
Comment 3 Sebastien Pouliot 2015-09-29 13:18:16 UTC
It's not available in the stable channel. You can either
- try the alpha channel (which has XS 5.10);
- contact support (see yellow banner on top of this page); or
- wait for the next stable release.

*** This bug has been marked as a duplicate of bug 31424 ***
Comment 4 Geoffrey 2015-09-30 04:51:09 UTC
hello Sebastien

i've downloaded the beta 5.9.7 build 12 beta and signing worked.
I close this bug and thank you for your help