Bug 34357 - Typo in error message "error MT1107: Application failed to launch: Etimed out trying to launch app"
Summary: Typo in error message "error MT1107: Application failed to launch: Etimed out...
Status: RESOLVED UPSTREAM
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: master
Hardware: Macintosh Mac OS
: --- trivial
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-28 15:57 UTC by Kent Green [MSFT]
Modified: 2015-09-28 16:06 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Xamarin Studio logs from my repo of issue (309.69 KB, application/zip)
2015-09-28 15:57 UTC, Kent Green [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description Kent Green [MSFT] 2015-09-28 15:57:33 UTC
Created attachment 13105 [details]
Xamarin Studio logs from my repo of issue

## Overview
As seen in bug #34353, which is the error that triggers this error message being displayed. 

> error MT1107: Application failed to launch: Etimed out trying to launch app
"Etimed"

## Steps to reproduce
This can be reproduced by creating a scenario which will time out while trying to launch the app. Here's the steps I used to reproduce bug #34353:
1. Create a new iOS Single View Unified Template App
2. Set the deployment target to 7.1 (or lower)
3. Build and deploy the app
4. App times out when being launched displaying "Etimed out trying to launch app"

## Expected Results
Error message should read:
> error MT1107: Application failed to launch: Timed out trying to launch app
(Or something similar)

## Build Information
=== Xamarin Studio ===

Version 5.9.7 (build 9)
Installation UUID: 8ef63a7c-1b18-40de-a334-7f78777fcb55
Runtime:
    Mono 4.0.4 ((detached/cb6d6b2)
    GTK+ 2.24.23 (Raleigh theme)

    Package version: 400040002

=== Apple Developer Tools ===

Xcode 6.4 (7720)
Build 6E35b

=== Xamarin.iOS ===

Version: 9.0.1.20 (Business Edition)
Hash: d8e9592
Branch: master
Build date: 2015-09-18 23:22:05-0400

=== Xamarin.Android ===

Version: 5.1.6.7 (Business Edition)
Android SDK: /Users/kentgreen/Library/Developer/Xamarin/android-sdk-macosx
    Supported Android versions:
        4.0.3  (API level 15)
        4.1    (API level 16)
        4.2    (API level 17)
        4.3    (API level 18)
        4.4    (API level 19)
        4.4.87 (API level 20)
        5.0    (API level 21)
        5.1    (API level 22)
Java SDK: /usr
java version "1.8.0_51"
Java(TM) SE Runtime Environment (build 1.8.0_51-b16)
Java HotSpot(TM) 64-Bit Server VM (build 25.51-b03, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.0.2.111 (Business Edition)

=== Build Information ===

Release ID: 509070009
Git revision: 31fa64709030b3edb971237780a452a4c69943c4
Build date: 2015-09-17 11:44:37-04
Xamarin addins: b105d33d8cd72911ff2cf3ee0b7715d37e5f19a6

=== Operating System ===

Mac OS X 10.10.5
Darwin Kents-MBP 14.5.0 Darwin Kernel Version 14.5.0
    Wed Jul 29 02:26:53 PDT 2015
    root:xnu-2782.40.9~1/RELEASE_X86_64 x86_64

## Additional Info
Adding XS logs from my reproduction of the issue.
Comment 1 Kent Green [MSFT] 2015-09-28 15:59:54 UTC
Adding Bug 34353 
"Extremely slow app launch time on iPhone 4 iOS 7.1.1 device"

As a "see also" link.
Comment 2 Sebastien Pouliot 2015-09-28 16:06:24 UTC
The MT1107 error message, past the "Application failed to launch:" string, comes from Apple.