Bug 34344 - Application fails to build in Visual Studio 2015 with Could not AOT the assembly ... SQLite.Net.dll
Summary: Application fails to build in Visual Studio 2015 with Could not AOT the assem...
Status: RESOLVED INVALID
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 8.10
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-28 11:26 UTC by Milen`
Modified: 2015-09-29 07:03 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Build output with -v -v -v -v on (17.33 KB, text/plain)
2015-09-29 04:43 UTC, Milen`
Details
debug output when running in simulator (15.23 KB, text/plain)
2015-09-29 04:54 UTC, Milen`
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Milen` 2015-09-28 11:26:30 UTC
iPad running iOS 9 Mac has Xcode 6.4 and Xamarin iOS v8.10.5.26
Windows machine - Windows 8.1 Pro, Visual Studio 2015, Xamarin iOS 8.10.5.0 and Xamarin 3.11.894
Full error shown bellow:
Could not AOT the assembly '/Users/myusername/Library/Caches/Xamarin/mtbs/builds/appname/e5a973c32e4775f32e4fa9e86d15b3f6/obj/iPhone/Debug/mtouch-cache/64/Build/SQLite.Net.dll'
Comment 1 Sebastien Pouliot 2015-09-28 16:40:29 UTC
Can you attach both:

1. your full build log, with "-v -v -v -v" added to your "Additional mtouch arguments";

2. a zip with the content of your "mtouch-cache" directory ?
Comment 2 Milen` 2015-09-29 04:43:21 UTC
Created attachment 13117 [details]
Build output with -v -v -v -v on
Comment 4 Milen` 2015-09-29 04:49:47 UTC
Update: I downgraded my iPad to 8.4.1 and still have this issue, all files provided are based on my iPad running iOS 8.4.1
Comment 5 Milen` 2015-09-29 04:54:03 UTC
Created attachment 13118 [details]
debug output when running in simulator

When I use iPhoneSimulator the app starts but encounters numerous exceptions, file attached with debug output
Comment 6 Milen` 2015-09-29 07:03:47 UTC
Downgraded to iOS 8.4.1 on device and full Xamarin reinstall on Windows and Mac machines did the job for me. Had to also rebuild and deploy from Mac first