Bug 3429 - Error while using 'Create android package' feature
Summary: Error while using 'Create android package' feature
Status: CLOSED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: unspecified
Hardware: PC Mac OS
: High normal
Target Milestone: ---
Assignee: shana@xamarin.com
URL:
Depends on:
Blocks:
 
Reported: 2012-02-13 13:54 UTC by Eric Beisecker
Modified: 2012-03-26 16:53 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description Eric Beisecker 2012-02-13 13:54:35 UTC
Current Behavior: When selecting the 'Create Android Package' option under the 'Project' menu MonoDevelop creates the Package under /bin/{Debug, Release}/ but fails to move it to the location specified in the create package Dialog. (Permission error)

Expected Behavior: The 'Create Android Package' feature should work without error and create an Android packaged in the location Specified in the dialog. 

Steps: 
1) Open a MonoDroid application
2) Select 'Project->Create Android Package'
3) Enter a File Location and Name in the 'Create Android Package' dialog
4) Click "Ok"

Error produced: http://screencast.com/t/Afm5LsyUa


Versions:
MonoDevelop 2.8.6.4
Mono for Android: 4.0.3.85258578
Comment 1 Jeffrey Stedfast 2012-02-15 16:05:15 UTC
I'm not able to reproduce the error in 2.8.6.4, but I can conform that the HelloM4A.HelloM4A.apk is not saved to the location specified.

In git master, however, it is saved where the user specifies in the dialog (once again, no error).

I'm using the same version of Mono4Android: Mono for Android: 4.0.3.85258578

I don't know if this has been fixed, or if there is a different setup between my machine and Eric's.
Comment 2 Eric Beisecker 2012-03-26 16:53:34 UTC
Issue seems fixed in 2.8.8.3