Bug 34218 - Resource.Designer.cs does not update on Clean and Rebuild
Summary: Resource.Designer.cs does not update on Clean and Rebuild
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 5.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2015-09-23 16:45 UTC by Mike Rowley
Modified: 2017-06-28 11:38 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Mike Rowley 2015-09-23 16:45:38 UTC
If the .csproj file is missing the following entry, the Resource.Designer.cs does not get rebuilt.  And therefore any android resources added to the project are not accessible at run time.

<AndroidResgenFile>Resources\Resource.Designer.cs</AndroidResgenFile>

Adding this line to an affected .csproj file, reloading, cleaning then rebuilding the
project regenerated the Resource.Designer.cs file as expected and the absent resource files are available at run time.

I would like to see a compiler warning or error at build if this entry is missing from an android project file.
Comment 1 Przemysław Raciborski 2015-10-09 07:44:31 UTC
at most warning - I'd like to have this disabled in most cases (cause it slow downs operations like adding new image asset to project when your resource.designer.cs file has ~9k LOC)
Comment 2 Abhishek 2016-01-15 15:03:03 UTC
I have tried this issue and unable to reproduce this issue at my end.

Could you please attached the sample along with the bug so that I can reproduce this issue at my end. Also it would be great if you provide the IDE Log and Environment Info.

Ide log via Help->Open Log Directory.
Environment Info: Help->About->Show Details.

Environment Info:

=== Xamarin Studio ===

Version 5.10.2 (build 51)
Installation UUID: 61a4d1a2-9a82-4af4-ba5d-17d931fd960a
Runtime:
	Microsoft .NET 4.0.30319.42000
	GTK+ 2.24.23 (MS-Windows theme)
	GTK# 2.12.30

=== Xamarin.Profiler ===

Not Installed

=== Xamarin.Android ===

Version: 6.0.1.5 (Starter Edition)
Android SDK: E:\android-sdk
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)

SDK Tools Version: 24.4.1

SDK Platform Tools Version: 23.0.1

SDK Build Tools Version: 23.0.2


Java SDK: C:\Program Files (x86)\Java\jdk1.7.0_71
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) Client VM (build 24.71-b01, mixed mode, sharing)

=== Xamarin Android Player ===

Not Installed

=== Build Information ===

Release ID: 510020051
Git revision: 36453d5e06a1ad2cc8d261ad32e29abe0ed57c1f
Build date: 2016-01-12 14:16:50-05
Xamarin addins: ab25321e8918350655a7d46c86cfbaac3222fd3c
Build lane: monodevelop-windows-cycle6-c6sr1

=== Operating System ===

Windows 6.3.9600.0 (64-bit)
Comment 3 Adam Hartley [MSFT] 2017-06-28 11:38:16 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!