Bug 34166 - [Profiler] Xamarin Studio crashes when being profiled.
Summary: [Profiler] Xamarin Studio crashes when being profiled.
Status: VERIFIED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Profiler ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: 4.6.0 (C8)
Assignee: Alex Rønne Petersen
URL:
: 35435 ()
Depends on:
Blocks:
 
Reported: 2015-09-22 11:36 UTC by Marius Ungureanu
Modified: 2016-09-06 13:31 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Marius Ungureanu 2015-09-22 11:36:02 UTC
1. Have Xamarin Studio installed.
2. Open Xamarin Studio.app through Xamarin Profiler.
3. Observe that it crashes after a while.

https://gist.github.com/Therzok/03ba22d03b6e27625234
Comment 1 Alex Rønne Petersen 2015-11-03 01:23:38 UTC
*** Bug 35435 has been marked as a duplicate of this bug. ***
Comment 2 Alex Rønne Petersen 2016-09-01 16:50:08 UTC
Fix is in C8.
Comment 3 Arpit Jha 2016-09-05 06:34:44 UTC
@Marius ,I think 2nd steps in bug description will be “ Open xamarin profiler using Xamarin Studio”  

I have checked this issue with following steps to verify.

1. Installed latest C8 builds.
2. Launch Xamarin Studio.
3. Create a Xamarin.IOS Single view application.
4. Start profiling from  XS Menu -> Run -> Start Profiling.
5. xamarin profiler launched  
6. profiler working fine without any Xamarin Studio or Xamarin Profiler crashed.


Screencast : 
http://www.screencast.com/t/ZeY1XRVvjdT
 XS About & IDE logs : https://gist.github.com/Arpit360/5ffda56e6e0eae1bed0f93f66ef37256

Please let me know if I need to check anything else to verify this issue.
Comment 4 asimk 2016-09-06 13:31:49 UTC
As per comment 3 changing status to verified.