Bug 33998 - * Assertion at ../../../../../mono/mono/utils/mono-threads.c:170, condition `result' not met
Summary: * Assertion at ../../../../../mono/mono/utils/mono-threads.c:170, condition `...
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: Pre-release ()
Version: XI 8.0.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-16 03:59 UTC by Bülent Güler
Modified: 2016-06-09 01:12 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Bülent Güler 2015-09-16 03:59:33 UTC
I get the following error when I call the method btnraporla_click

public static Thread t,t2;
		
private void btnRaporla_Click(object sender, EventArgs e)
{			
			
try
{
				
	t = new Thread(new ThreadStart(pushProcessing));
	t.Start();	
				
	t2 = new Thread(new ThreadStart(WaitForReport));
	t2.Start();	
				
				
				
}
catch
{
	GiveAlert("");
}				
}		
 * Assertion at ../../../../../mono/mono/utils/mono-threads.c:170, condition `result' not met

2015-09-16 10:50:55.802 Diva[615:154694] critical: 	0   Diva                                0x0068b6ef mono_handle_native_sigsegv + 238
2015-09-16 10:50:55.803 Diva[615:154694] critical: 	1   Diva                                0x0068f5bd sigabrt_signal_handler + 104
2015-09-16 10:50:55.804 Diva[615:154694] critical: 	2   libsystem_platform.dylib            0x348e787b _sigtramp + 42
2015-09-16 10:50:55.805 Diva[615:154694] critical: 	3   libsystem_pthread.dylib             0x348ebcbb pthread_kill + 62
2015-09-16 10:50:55.805 Diva[615:154694] critical: 	4   libsystem_c.dylib                   0x3480b891 abort + 76
2015-09-16 10:50:55.806 Diva[615:154694] critical: 	5   Diva                                0x0072e9bc log_callback + 80
2015-09-16 10:50:55.807 Diva[615:154694] critical: 	6   Diva                                0x0071cfd3 log_adapter + 170
2015-09-16 10:50:55.807 Diva[615:154694] critical: 	7   Diva                                0x00724f71 monoeg_assertion_message + 76
2015-09-16 10:50:55.808 Diva[615:154694] critical: 	8   Diva                                0x0071f359 mono_thread_info_detach + 0
2015-09-16 10:50:55.809 Diva[615:154694] critical: 	9   Diva                                0x0071eef3 inner_start_thread + 42
2015-09-16 10:50:55.809 Diva[615:154694] critical: 	10  libsystem_pthread.dylib             0x348eae17 <redacted> + 138
2015-09-16 10:50:55.810 Diva[615:154694] critical: 	11  libsystem_pthread.dylib             0x348ead8b _pthread_start + 118
2015-09-16 10:50:55.811 Diva[615:154694] critical: 	12  libsystem_pthread.dylib             0x348e8b14 thread_start + 8
2015-09-16 10:50:55.811 Diva[615:154694] critical: 
=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================
Comment 2 PJ 2015-09-16 13:13:33 UTC
Hi Bülent,

Thanks for the report - the most efficient way for us to diagnose the issue is if we can reproduce it easily. If possible, can you zip up a build-able version of the test case and attach it?

It will also help us to get context if you provide the version information. Can you add the full version information from Xamarin Studio -> About Xamarin Studio?

Thanks!
Comment 3 Sebastien Pouliot 2016-06-09 01:12:16 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!