Bug 33993 - Selecting Default Text Color on button does not work
Summary: Selecting Default Text Color on button does not work
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS Designer ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-15 19:29 UTC by Martin McNally
Modified: 2015-09-16 12:09 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Martin McNally 2015-09-15 19:29:05 UTC
If you have a Button Text color set to a custom color. Then if you try to change that back to default by pressing the default button. It does not work. It keeps the custom color. 

This is the storyboard designer in Visual Studio.
Comment 1 Martin McNally 2015-09-15 19:36:51 UTC
Actually slight update to this. It seems when you add a button to the storyboard it starts out with a custom color rather than the default. I guess that is the issue.
Comment 2 Alan McGovern 2015-09-16 12:09:05 UTC
You were close! The problem was that we were writing a custom colour instead of reverting to the default value when you selected 'Default' in the colour picker.

This issue affects most (all?) color entries but the workaround is simple enough: If you want to go to the actual default color, open the storyboard file as text and remove the line which sets the colour. 

When you change the Text Colour in a UIButton the xml is set in the corresponding button state:
<state key="normal" title="Button">
    <color key="titleShadowColor" white="0.5" alpha="1" colorSpace="calibratedWhite"/>
    <color key="titleColor" colorSpace="calibratedRGB" red="1" green="0" blue="0" alpha="1"/>
</state>

If you want to reset to the default you'd just have to remove the line which has key="titleColor".

This fix is being rolled into the current releases so it should be in an alpha release in the near future.