Bug 33890 - CancelButtonColor for SearchBar does not work on iOS
Summary: CancelButtonColor for SearchBar does not work on iOS
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 1.5.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: E.Z. Hart [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-09-11 11:04 UTC by Adam Hartley [MSFT]
Modified: 2015-10-08 08:40 UTC (History)
6 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample (4.73 MB, application/zip)
2015-09-11 11:04 UTC, Adam Hartley [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Adam Hartley [MSFT] 2015-09-11 11:04:20 UTC
Created attachment 12873 [details]
Sample

## Overview 

Setting CancelButtonColor does not have any effect on iOS.

## Steps to reproduce

1. Sample is included in the attachment
2. Run the iOS project
3. Tap in the search bar
4. Type a few characters for the cancel button to display

## Expected result

Cancel button should be the colour defined, in this case red.

## Actual result

Cancel button is still the default blue.

## Notes 

Not able to reproduce on Android.
Comment 1 Paul DiPietro [MSFT] 2015-09-11 15:30:06 UTC
Checked with 1.5.0-pre3 and the issue appears under that as well.
Comment 2 Rui Marinho 2015-09-30 11:54:56 UTC
Should be fixed in 1.5.1-pre1
Comment 3 Parmendra Kumar 2015-10-08 08:40:00 UTC
I have checked this issue with Xamarin.Forms 1.5.1-pre1 and its working fine.


Hence closing this issue.