Bug 33866 - Breakpoint not hit in multiple partial App classes
Summary: Breakpoint not hit in multiple partial App classes
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.5.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-10 17:59 UTC by Mike Rowley
Modified: 2016-01-20 13:23 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample code to reproduce the bug (271.36 KB, application/octet-stream)
2015-09-10 18:00 UTC, Mike Rowley
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Mike Rowley 2015-09-10 17:59:15 UTC
I have run across an issue in Xamarin.Forms (both iOS and Android) where breakpoints are not hit in the App class if there are two App classes declared as partials.
    public partial class App : Application

I have attached a sample to illustrate the issue.

As it stands a breakpoint in the App class wont stop the debugger, however if you move the WelcomeString variable from the second App class (App.Clients.cs) and put it back in App.cs and rename the second App class the breakpoint will be hit.

I have tried this on other partials and the debugger stops as expected, it just seems to happen on App and only if there are actually two partials, simply declaring the only App class a partial doesn’t prevent the debugger from stopping on the breakpoint.

I am using VS2015 & Xamarin 3.11.893.0
Comment 1 Mike Rowley 2015-09-10 18:00:47 UTC
Created attachment 12861 [details]
Sample code to reproduce the bug
Comment 2 Stephane Delcroix 2016-01-20 13:23:03 UTC
I wasn't able to reproduce this issue on this day, with updated xamarin version (but your project and your XF version).
I guess the debugger had an issue that was fixed.
If you can still reproduce this problem, please reopen the bug, and we will need to reassign it to the debugger or runtime teams.

Warm regards,

the xf team