Bug 33839 - cannot run debug for fire phone OS 4.6.3
Summary: cannot run debug for fire phone OS 4.6.3
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-10 03:55 UTC by Peter
Modified: 2017-06-30 02:40 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Peter 2015-09-10 03:55:38 UTC
cannot run debug for fire phone OS 4.6.3

log info for application output
Forwarding debugger port 8904
Detecting existing process

log info from deploying to device
Detecting installed packages

Deployment failed because of an internal error: 'ps' output not recognized

Deployment failed. Internal error.


Xamarin Studio
Version 5.9.5 (build 9)
Installation UUID: e9f7ea4b-7849-420b-9af6-1f9014618a30
Runtime:
	Mono 4.0.3 ((detached/d6946b4)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400030020

Apple Developer Tools
Xcode 6.4 (7720)
Build 6E35b

Xamarin.iOS
Version: 8.10.4.46 (Starter Edition)
Hash: 2c66d2f
Branch: master
Build date: 2015-08-04 13:52:25-0400

Xamarin.Android
Version: 5.1.5.3 (Indie Edition)
Android SDK: /Users/peterou/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
Java SDK: /usr
java version "1.7.0_75"
Java(TM) SE Runtime Environment (build 1.7.0_75-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.75-b04, mixed mode)
Comment 1 Peter 2015-09-11 14:00:14 UTC
Find the reason and implement a solution to solved it.
because the ps command on fire phone output format is,
USER     PID   PPID  VSIZE  RSS      OOM  WCHAN    PC         NAME
root      1     0     932    460     -16 ffffffff 00000000 S /init

and the normal android ps command output like this,
USER     PID   PPID  VSIZE  RSS     WCHAN    PC         NAME
root      1     0     932    520   c025f414 0001da80 S /init

So i think that the Xamarin Studio cannot parse the output string format correctly.

My solution is ,
1. root the fire phone first.
2.replace the ps command in the /system/bin/ folder on fire phone.

ps: I pull the same version's ps command file from the simulator, and it works well.

Hope this can help you guys.
Comment 2 Cody Beyer (MSFT) 2017-06-30 02:40:27 UTC
Hey,

I was able to debug against my fire phone using the latest Xamarin. If you are still having issues, please reopen this bug with a the latest version information that you have.

Thanks!