Bug 33836 - ViewCell text cuts in WP8.1 after scrolling
Summary: ViewCell text cuts in WP8.1 after scrolling
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 1.4.4
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-10 02:54 UTC by Dushyant Bangal
Modified: 2017-01-03 22:57 UTC (History)
2 users (show)

Tags: Windows ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample Project (1.95 MB, application/octet-stream)
2015-09-10 02:59 UTC, Dushyant Bangal
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Dushyant Bangal 2015-09-10 02:54:23 UTC
I've added the WP8.1 project as per Xamarin's guide.
This happens only in case of ViewCell.

Steps to reproduce:
1) Create ListView
2) Create a ViewCell in its DataTemplate
3) Put label in the ViewCell
4) Bind the label
5) Load contents in ListView
6) Scroll down
7) Scroll up

Actual Result:
If font size is small, the lines disappear
If font size is medium/large, the text gets cut


I'm attaching a sample project.
If you dont get the bug, try uncommenting some of the code that adds more items. This is usually happening when items are Added. I didnt get the bug a few times when the ObservableCollection is directly created from another.

Also, if frame is used, the whole listitem disappears.
Comment 1 Dushyant Bangal 2015-09-10 02:59:52 UTC
Created attachment 12844 [details]
Sample Project

I had to delete packages to reduce size. Please re add them.

Also, if you dont get the bug, try uncommenting some of the code which adds more items to the listview
Comment 3 Jimmy [MSFT] 2017-01-03 22:57:18 UTC
I can no longer reproduce this issue when using Forms 2.3.3.175.