Bug 33612 - Removing a page from the navigation stack causes an 'Object reference' exception in Android only
Summary: Removing a page from the navigation stack causes an 'Object reference' except...
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 1.4.4
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: E.Z. Hart [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-09-03 13:57 UTC by Rob DeRosa
Modified: 2015-10-26 06:31 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Rob DeRosa 2015-09-03 13:57:42 UTC
Created attachment 12739 [details]
Sample projects

I've attached a sample project that illustrates the exception.

Steps to reproduce:

1) launch app
2) Click on 'Go to page 3'
3) Click on the first button 'Worked....etc'
4) Now that you're on page 4, click on the button 'Clear nav stack.... etc' - exception occurs

This works fine on iOS but bombs out on Android.
Comment 1 Jason Smith [MSFT] 2015-10-09 23:08:00 UTC
Should be fixed in 1.5.2-pre1
Comment 2 Parmendra Kumar 2015-10-26 06:31:48 UTC
I have checked this issue with Xamarin.Forms  1.5.2-pre2 and its working fine.

Hence closing this issue.