Bug 33564 - Issues with Minimum version numbers starting with a 0.
Summary: Issues with Minimum version numbers starting with a 0.
Status: RESOLVED FIXED
Alias: None
Product: Components
Classification: Xamarin
Component: Visual Studio Integration ()
Version: Production (addons.xamarin.com)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-02 04:57 UTC by Ross Dargan
Modified: 2016-01-07 18:56 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Error message after version number correction (40.02 KB, image/png)
2015-09-02 14:56 UTC, Matthew Leibowitz
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Ross Dargan 2015-09-02 04:57:15 UTC
When you add ToastIOS component version 1.05 the project adds 1.5 instead of 1.05.

I.E.

    <XamarinComponentReference Include="ToastIOS">
      <Visible>False</Visible>
      <Version>1.5</Version>
      <InstallationInProgress>True</InstallationInProgress>
    </XamarinComponentReference>   

is wrong it should be

    <XamarinComponentReference Include="ToastIOS">
      <Visible>False</Visible>
      <Version>1.05</Version>
      <InstallationInProgress>True</InstallationInProgress>
    </XamarinComponentReference>
Comment 1 Matthew Leibowitz 2015-09-02 14:50:45 UTC
I can confirm this bug with:
Microsoft Visual Studio Professional 2015
Version 14.0.23107.0 D14REL
Microsoft .NET Framework
Version 4.6.00079

Installed Version: Professional

Xamarin   3.11.837.0 (f10676f)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   5.1.5.3 (f98871a95a479f6d71b3067b7e5834d41fcb2118)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS   8.10.4.0 (6db87c53c073f4af2f5247fb738a27ea08c094fd)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration
Comment 2 Matthew Leibowitz 2015-09-02 14:56:42 UTC
Created attachment 12723 [details]
Error message after version number correction

I tried changing the version number in the .csproj to 1.05, but VS still reports an error.

I can confirm that the reference was added correctly though. It references the correct version number (1.05)
Comment 3 David Humphreys 2016-01-07 18:56:57 UTC
Just tried this with the latest version of Xamarin.iOS for Visual Studio and it correctly added 1.05.