Bug 33556 (Verwijs) - Critical: Running .NET on OpenSUSE Linux 13.2 crashes with thread overload...
Summary: Critical: Running .NET on OpenSUSE Linux 13.2 crashes with thread overload...
Status: RESOLVED FIXED
Alias: Verwijs
Product: Runtime
Classification: Mono
Component: Debugger ()
Version: 3.8.0
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL: https://drive.google.com/file/d/0B4_T...
Depends on:
Blocks:
 
Reported: 2015-09-01 15:39 UTC by André Verwijs
Modified: 2015-11-23 08:34 UTC (History)
3 users (show)

Tags: OpenSUSE threads runtime
Is this bug a regression?: ---
Last known good build:


Attachments
mono-crash-running-NET-on-Linux (57.26 KB, text/plain)
2015-09-01 15:39 UTC, André Verwijs
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description André Verwijs 2015-09-01 15:39:50 UTC
Created attachment 12708 [details]
mono-crash-running-NET-on-Linux

OS:
- Linux 3.16.7-24-desktop - OpenSUSE 13.2 (Harlequin) (x86_64)
- KDE 4.14.9
- Mono version 3.8.0 (3.8.0-1.4 vr 10 okt 2014 17:09:03 CEST) (tarball Fri Oct 10 15:00:11 UTC 2014)


when running Windows .NET code on (OpenSUSE)Linux (13.2) still crashes with thread overload.
tips on fixes and/or performance improvement are welcome....


view stacktrace online here:
https://drive.google.com/file/d/0B4_TSVggahj8MDFOMVR1V2dUc3M/view?usp=drivesdk 

or see attachment.... 


for other information, please ask...
Comment 1 Zoltan Varga 2015-09-01 15:42:25 UTC
Try mono version 4.0 or later, it might fix the problem.
Comment 2 André Verwijs 2015-09-01 15:45:54 UTC
does 4.0 have performance improvements..??  not sure if this is stable...
Comment 3 Zoltan Varga 2015-09-01 15:52:35 UTC
4.0 is the current stable mono version.
Comment 4 André Verwijs 2015-09-01 15:58:07 UTC
I will try... thanks
Comment 5 Alexis Christoforides 2015-11-23 08:34:19 UTC
Closing bug, feel free to reopen if you are having the same issue with 4.0 or 4.2.