Bug 33543 - [Master]Building after migrating form MonoMac=>Xamarin.Mac=>Xamarin.Mac Unified API Getting licence trigger.
Summary: [Master]Building after migrating form MonoMac=>Xamarin.Mac=>Xamarin.Mac Unifi...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Activation ()
Version: Master
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2015-09-01 11:16 UTC by Rajneesh Kumar
Modified: 2015-10-07 07:21 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Chris Hamons 2015-09-01 11:27:37 UTC
Could you attach the converted project to the bug?
Comment 3 Chris Hamons 2015-09-01 11:35:39 UTC
Thanks!
Comment 4 Chris Hamons 2015-09-11 16:02:12 UTC
This is even worse. It appears that XM 4.5 is broken under Indie completely:

https://bugzilla.xamarin.com/show_bug.cgi?id=33898
Comment 5 Chris Hamons 2015-09-15 16:05:12 UTC
Should be fixed by master / da39974bb612875ca7de8a030d66002ec9bd6021. Also in C6.
Comment 6 Rajneesh Kumar 2015-10-07 07:21:00 UTC
I have checked tis issue with cycle 6 build
xamarin.mac-2.4.0.79_b5396c29ec2b327de2dd542c8d57fd7312368ba7 and observed that this issue no longer exist with this build. Now no building after migrating form MonoMac=>Xamarin.Mac=>Xamarin.Mac Unified API  user does't getting any licence trigger and able to build and run successfully. 

Screencast:  http://www.screencast.com/t/rYpKfphNH

This issue has been fixed, hence I am closing this issue.

Thanks..!

Environment info:

 === Xamarin Studio ===

Version 5.10 (build 812)
Installation UUID: 0922fe35-7ea3-4736-b7b6-9eddaf47d514
Runtime:
	Mono 4.2.1 (explicit/cc1cf60)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010062

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.0 (8227)
Build 7A220

=== Xamarin.iOS ===

Version: 9.2.0.84 (Starter Edition)
Hash: b5396c2
Branch: master
Build date: 2015-09-30 15:22:15-0400

=== Xamarin.Android ===

Version: 6.0.0.9 (Starter Edition)
Android SDK: /Users/360logica/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)

SDK Tools Version: 24.4.0
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

=== Xamarin Android Player ===

Version: 0.6.1
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.4.0.79 (Starter Edition)

=== Build Information ===

Release ID: 510000812
Git revision: feb7640e9c013af8bb30a6a72e5c3d2ebcefdcbd
Build date: 2015-10-02 19:15:27-04
Xamarin addins: f99ff0a7da6a31661870ef3567390a7e84e9a3c4
Build lane: monodevelop-lion-cycle6

=== Operating System ===

Mac OS X 10.11.0
Darwin 360Logicas-MacBook-Pro.local 15.0.0 Darwin Kernel Version 15.0.0
    Wed Aug 26 16:57:32 PDT 2015
    root:xnu-3247.1.106~1/RELEASE_X86_64 x86_64