Bug 33385 - ScrollView returns to begging on TranslateTo
Summary: ScrollView returns to begging on TranslateTo
Status: RESOLVED ANSWERED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-08-25 23:53 UTC by Ege Aydin
Modified: 2018-03-15 20:22 UTC (History)
18 users (show)

Tags: ac, scrollview, translateto, ios
Is this bug a regression?: ---
Last known good build:


Attachments
scrollview demo page (2.88 KB, application/octet-stream)
2017-08-30 00:57 UTC, David Ortinau [MSFT]
Details
scrollview demo page (2.87 KB, application/octet-stream)
2017-08-30 01:00 UTC, David Ortinau [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Ege Aydin 2015-08-25 23:53:21 UTC
Well when I call TranslateTo an scrollview on Xamarin.Forms, it's both ScrollX and ScrollY becomes 0.
Comment 1 George Cook 2015-09-01 14:01:13 UTC
yes - any invalidate does it. It makes this control utterly unusable. I even tried working around it with custom renderers; but like most forms code, you guys seal/hide the members necessary to do so.

This therefore needs to be fixed - there is no workaround.
Comment 2 Ege Aydin 2015-09-02 05:02:41 UTC
Actually there is a workaround. Someone from SO suggested it. Put the scrollview inside a contentview than translate the contentview. Scroll indexes won't be becoming 0 anymore.
Comment 3 Michiel van Vlaardingen 2015-09-15 09:00:26 UTC
Unfortunately that workaround does not work for other cases where it occurs such as the size of the scrollview changing.
Comment 4 adrianknight89 2016-09-21 19:50:04 UTC
Similar to: https://bugzilla.xamarin.com/show_bug.cgi?id=43947
Comment 5 gareth 2017-05-18 06:30:21 UTC
Is there an update on a fix for this issue?
Comment 6 David Ortinau [MSFT] 2017-08-30 00:57:14 UTC
Created attachment 24466 [details]
scrollview demo page

I'm not able to reproduce this on 2.4.0.269-pre2.
Comment 7 David Ortinau [MSFT] 2017-08-30 01:00:33 UTC
Created attachment 24467 [details]
scrollview demo page

Apologies, I wasn't using TranslateTo. I see now it changes ScrollX/ScrollY to 0.
Comment 8 David Ortinau [MSFT] 2017-08-30 01:12:45 UTC
This appears to be iOS. Android behaves properly.
Comment 9 tyxongorki 2017-10-10 14:45:58 UTC
Hi David. Any update on this issue?
I can still reproduce it on 2.4.0.280. Suggested workaround doesn`t work for me. Thanks
Comment 10 Paul Brenner 2018-03-15 15:46:44 UTC
See https://github.com/xamarin/Xamarin.Forms/issues/2110
Comment 11 Samantha Houts [MSFT] 2018-03-15 20:22:35 UTC
Please follow the issue on GitHub for updates. Thanks!