Bug 33371 - Xamarin Profiler crashes immediately when attempting to profile on physical device
Summary: Xamarin Profiler crashes immediately when attempting to profile on physical d...
Status: RESOLVED DUPLICATE of bug 31023
Alias: None
Product: Profiler
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Rodrigo Moya
URL:
Depends on:
Blocks:
 
Reported: 2015-08-25 15:08 UTC by Patrick Lind
Modified: 2015-09-10 04:26 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Zip of the error log we are encountering. (1.90 KB, application/zip)
2015-08-25 15:08 UTC, Patrick Lind
Details
Log of exception from console output (11.04 KB, text/plain)
2015-09-09 10:13 UTC, Nick Turner
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 31023

Description Patrick Lind 2015-08-25 15:08:16 UTC
Created attachment 12635 [details]
Zip of the error log we are encountering.

I go to Xamarin Studio 5.9.5 (build 10) for my iOS application and then do Run -> Start Profiling with my physical device selected as the debug option.  When I do this I get the following error in the attached error log.  Any idea what's going on here?

In the log I'm thinking this is the main issue:

ERROR[2015-08-25 14:59:02Z]: error stopping iOS application
System.IO.IOException: USB stream error: EPIPE
Comment 1 Rodrigo Moya 2015-09-01 07:27:31 UTC
The logs show the app is crashing, I guess because of the watchdog in iOS. So, could you please see if you can get a crash report/iOS device logs? Logs can be accessed from Xamarin Studio (via View -> Pads -> iOS Device Log. For crash reports, use the Devices tool in XCode (Window -> Devices).
Comment 2 Nick Turner 2015-09-09 10:11:48 UTC
I am getting this error with an empty dictionary. I have attached the log. It's running an endless loop with connection failure -61

See log for details

Xamarin Studio
Version 5.9.4 (build 5)
Installation UUID: c6203825-3923-493f-a5db-a2fbb7533e87
Runtime:
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

Apple Developer Tools
Xcode 6.3.2 (7718)
Build 6D2105

Xamarin.iOS
Version: 8.10.3.2 (Business Edition)
Hash: 8b265d6
Branch: master
Build date: 2015-06-30 15:19:13-0400

Xamarin.Android
Version: 5.1.4.16 (Business Edition)
Android SDK: /Users/nturner/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.2   (API level 17)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-466.1-11M4716)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-466.1, mixed mode)

Xamarin Android Player
Version: Unknown version
Location: /Applications/Xamarin Android Player.app

Xamarin.Mac
Not Installed

Build Information
Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

Operating System
Mac OS X 10.10.3
Darwin nturnerMacBook.local 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 3 Nick Turner 2015-09-09 10:13:24 UTC
Created attachment 12836 [details]
Log of exception from console output

This shows the out of memory with the null exception. Appears it's looking for a failure in a loop until it crashes
Comment 5 Nick Turner 2015-09-09 10:18:33 UTC
I submitted the log privately for naming reasons.

I see it finally errors on condition 'ji' not met.
Comment 6 Rodrigo Moya 2015-09-10 04:26:05 UTC
Right, duplicated bug, so marking this as dup of bug #31023

*** This bug has been marked as a duplicate of bug 31023 ***