Bug 33284 - TableView SwitchCell Data Binding Issue
Summary: TableView SwitchCell Data Binding Issue
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 1.5.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-08-20 19:50 UTC by support
Modified: 2016-04-13 19:58 UTC (History)
2 users (show)

Tags: ac Windows
Is this bug a regression?: ---
Last known good build:


Attachments
zip (291.42 KB, application/x-zip-compressed)
2016-04-13 19:48 UTC, Chris King
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description support 2015-08-20 19:50:56 UTC
Hello Xamarin Support team,

I use Xamarin.Forms to create app for Windows Phone 8.1. 
Xamarin.Forms.Windows library is added to refer via NuGet. 

It seems that there are some unexpected behaviors in Data Biding of TableView - SwitchCell. 

If only Switch is used, the notification can be received from VM. 
However, once SwitchCell is used, any notifications cannot be received. 

Here is the URL to download the sample project: 
https://github.com/ytabuchi/Study/tree/master/XF_INPC

Please investigate this issue whether the problem is related in Xamarin or not. 

If you have any questions and concerns, please let us know. 

Thank you for your help.
Comment 1 Chris King 2016-04-13 19:48:43 UTC
Created attachment 15707 [details]
zip

as zip
Comment 2 Chris King 2016-04-13 19:58:02 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.