Bug 33244 - Disappearing ActivityIndicators in ListView when scrolling
Summary: Disappearing ActivityIndicators in ListView when scrolling
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.5.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Samantha Houts [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-08-20 00:54 UTC by Lionel Ong
Modified: 2016-11-15 19:56 UTC (History)
9 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample (1.35 MB, application/x-gzip)
2015-08-20 03:25 UTC, Lionel Ong
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Lionel Ong 2015-08-20 00:54:19 UTC
Scrolling up and down a ListView which contains a large number of running ActivityIndicator's causes some indicators to disappear and appear again sporadically.

Scenario:
1. ListView containing a large number of items. Each item in the list contains an ActivityIndicator with IsRunning = true. 
2. User scrolls up and down the list at varying speeds. 
Result:
Some indicators stop rendering when they go off the screen and back again. Scrolling more results in it rendering again sometimes.
Comment 1 Lionel Ong 2015-08-20 03:25:03 UTC
Created attachment 12578 [details]
Sample

Run the sample on the iOS emulator. Scroll up and down. Some activity indicators will start disappearing and appearing while you scroll.

Re-download nuget packages to run.
Comment 2 Parmendra Kumar 2015-08-20 09:24:04 UTC
I tried to reproduce this issue with attached sample project in bug description and able to reproduce it.

Screencast: http://www.screencast.com/t/N58eHq9Im

Simulator Log: https://gist.github.com/Parmendrak/fc574399808cfe64a0f6
IDE Log:https://gist.github.com/Parmendrak/acaab80e13325abd3802

I am getting same issue with X.F 1.5.0.6396-pre1 

Environment info:
Xamarin Studio 5.9.5 (build 10)
Mono 4.0.3 ((detached/d6946b4)
GTK+ 2.24.23 (Raleigh theme)
Package version: 400030020
Xcode 6.2 (6776)
Xamarin.iOS : 8.10.4.46 (Enterprise Edition)
Xamarin.Android : 5.1.5.3 (Enterprise Edition)
Mac OS X 10.9.4
Comment 3 Chris King 2016-04-13 19:30:38 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.