Bug 33205 - Adding an group to a listview that contains no items crashes on ios
Summary: Adding an group to a listview that contains no items crashes on ios
Status: RESOLVED DUPLICATE of bug 38067
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.5.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-08-18 16:41 UTC by Erik Renaud
Modified: 2016-04-13 19:23 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 38067

Description Erik Renaud 2015-08-18 16:41:02 UTC
Let`s say you have a listview with grouping enabled.

When adding a group without any items to the observable collection, it crashes on ios. i don`t have that problem on android.

The workaround was to add the item to the group and then add the group to the observable collection.
Comment 1 Parmendra Kumar 2015-08-20 13:35:27 UTC
@Erik,

I have tried to reproduce this issue and not able to reproduce it.
Could you please provide us sample project? so that we can reproduce this issue efficiently. 

Thanks..!
Comment 2 FieldstrikeMobile 2016-02-17 09:22:28 UTC
Duplicate of https://bugzilla.xamarin.com/show_bug.cgi?id=38067

?
Comment 3 Erik Renaud 2016-02-18 03:30:07 UTC
I think it`s a duplicate - i think we can close this one...
Comment 4 Chris King 2016-04-13 19:23:07 UTC
Resolve as dup with backlink.

*** This bug has been marked as a duplicate of bug 38067 ***