Bug 32836 - test_op_il_seq_point.sh - sed uses -E option
Summary: test_op_il_seq_point.sh - sed uses -E option
Status: CONFIRMED
Alias: None
Product: Tools
Classification: Mono
Component: other ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-08-06 14:41 UTC by Neale Ferguson
Modified: 2016-02-05 02:24 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 32836 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Neale Ferguson 2015-08-06 14:41:18 UTC
The test_op_il_seq_point.sh script in mono/mini uses a sed command that specifies the -E flag. However, this flag is not supported on Linux (or at least not on SLES11 SP3, CentOS 6.6 or Ubuntu 14.04.2):

get_method_name () {
        echo $1 | sed -E 's/.*Method (\([^)]*\) )?([^ ]*).*/\2/g'
}
Comment 1 Alexander Köplinger 2015-08-06 20:17:28 UTC
Hey Neale, that script does work for me on Ubuntu 14.04. It actually runs on the s390x boxes on Jenkins as well :)
Comment 2 Alexander Köplinger [MSFT] 2016-02-05 02:24:11 UTC
Interestingly, I found out today that GNU sed added the undocumented -E flag in the 4.2 release (which was released in 2009), and later on upgraded it to be documented: http://git.savannah.gnu.org/cgit/sed.git/commit/sed/sed.c?id=8b65e07904384b529a464c89f3739d2e7e4d5135

Looks like SLES11 SP3 ships with sed 4.1.5 which explains why it doesn't work there. Rewriting the ERE syntax into BRE should be straight-forward if you want to send a PR.