Bug 32647 - Profiler 0.19 - App crashes on startup when profiling
Summary: Profiler 0.19 - App crashes on startup when profiling
Status: RESOLVED DUPLICATE of bug 31023
Alias: None
Product: Profiler
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Rodrigo Moya
URL:
Depends on:
Blocks:
 
Reported: 2015-07-30 20:26 UTC by Joe Pro
Modified: 2015-08-14 08:59 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 31023

Comment 4 Rodrigo Moya 2015-07-31 04:44:12 UTC
Hi Joe

Can you please attach the logs/crash report for the application in the device? Logs can be accessed from XS via View->Pads->iOS device logs and crash reports via the Devices tool in Xcode.
Comment 6 Rodrigo Moya 2015-07-31 08:38:42 UTC
Seems to be a crash on the runtime profiler.
Comment 7 Joe Pro 2015-07-31 09:31:52 UTC
Thanks for looking into it.
Do I need to file the issue in a different area?
Comment 8 Rodrigo Moya 2015-07-31 10:40:34 UTC
No, don't worry, we'll re-assign this one to the correct product/person.

In fact, Alex from the runtime team thinks it might be a duplicate of bug #31023
Comment 9 Udham Singh 2015-08-13 13:09:17 UTC
I have checked this issue with below mono builds and able to reproduce the reported behaviour with these three builds.

MonoFramework-MDK-4.0.3.20.macos10.xamarin.x86_d6946b42e4062ca521d45ecd26baebbaf19c64b6 : latest stable mono

mono-MDK_a8cb543870c1177185e212e27e50ccdee5f4d60b : latest master mono 

MonoFramework-MDK-4.0.2.15.macos10.xamarin.x86_7c4679521b12ca38d29faeebc803abffd0c9a3f3  : latest  Cycle 5 Trunk 

Profiler Log : https://gist.github.com/Udham1/25089739d46ef56ab18a
iOS Device Log (Xcode) : https://gist.github.com/Udham1/da942c0f3ddf412c0066
Crash Log (Xcode) : https://gist.github.com/Udham1/2b23e0e5d412d0478018
Build Output : https://gist.github.com/Udham1/cdef894240ee930ef852

I have used iOS device iPhone 5S (iOS 7.1) to reproduce this issue.

Environment Info : 

=== Xamarin Studio ===

Version 5.9.5 (build 9)
Installation UUID: ce927b2a-2c07-44c5-b186-09cfdafba6dc
Runtime:
	Mono 4.3.0 (master/a8cb543)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 403000837

=== Apple Developer Tools ===

Xcode 6.2 (6776)
Build 6C131e

=== Xamarin.iOS ===

Version: 8.10.4.49 (Business Edition)
Hash: 7e598ef
Branch: master
Build date: 2015-08-08 12:28:27-0400

=== Build Information ===

Release ID: 509050009
Git revision: b99cb19a1d3b15d8980c4616f13f837457e5b292
Build date: 2015-07-28 02:01:44-04
Xamarin addins: d53d6eceb828422f3d4aff8547f2f6bab6c9ea58

=== Operating System ===

Mac OS X 10.9.5
Darwin Xamarin76s-Mac-mini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 10 Udham Singh 2015-08-14 08:59:12 UTC

*** This bug has been marked as a duplicate of bug 31023 ***