Bug 3264 - AutoComplete for code is not working properly.
Summary: AutoComplete for code is not working properly.
Status: RESOLVED DUPLICATE of bug 2751
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 2.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-02-08 07:58 UTC by akash
Modified: 2012-02-09 13:32 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 2751

Description akash 2012-02-08 07:58:36 UTC
When i create new View(.xml/.axml) file in folder Layout, it does not reflects in autocomplete for code in .cs code file. Please find below detail cases

Case 1:
I added new view test_view.xml file in layout folder and tried to access in code as Resource.Id. , here after '.' autocomplete feature lists the prevoius xml file but it is not listing test_view.xml file. 
So what i did was closed the MonoDroid IDE/tool  and restarted the MonoDroid IDE & i was able to see the test_view.xml file in autocompelete list.

Please make sure that it should appear in the autocomplete list without closing the IDE.

Case 2:
I then added new view custom_view.xml file in layout folder and deleted test_view.xml file but in the autocomplete list it was still showing test_view.xml and it was not showing custom_view.xml, where it should show custom_view.xml and not the test_view.xml in autocomplete list.

Please fix this , as it is the basic need of csharp developer.
Comment 1 akash 2012-02-08 08:07:57 UTC
Also same thing happens we we add any control in view.
for example,
When i add button in my existing view while accessing in the code behind it show not shows in autocomplete.
Comment 2 Jonathan Pobst 2012-02-08 10:21:40 UTC
You don't need to close the IDE, just rebuild the project and the autocompletion will get updated.  (Generally Ctrl-Shift-B).
Comment 3 Mikayla Hutchinson [MSFT] 2012-02-08 13:21:39 UTC
This was resolved. The fix will be in the next version of MonoDevelop.

*** This bug has been marked as a duplicate of bug 2751 ***
Comment 4 akash 2012-02-09 01:33:51 UTC
Hi Jonathan,

Thanks for the reply.

After rebuilding the  project/solution autocompletion does not get updated, any further suggestions ?
Comment 5 akash 2012-02-09 01:35:29 UTC
Hi Michael,

Thanks for the reply.

Could you please advise when can we except the fix in next version. ?
Comment 6 Mikayla Hutchinson [MSFT] 2012-02-09 13:32:27 UTC
I'm sorry, I cannot give a date for the next MD version, but it should be quite soon.