Bug 32584 - iOS Forms application loses toolbar and tab tint color
Summary: iOS Forms application loses toolbar and tab tint color
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 1.4.3
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-07-29 15:39 UTC by Eric Schmitz
Modified: 2016-11-15 03:50 UTC (History)
3 users (show)

Tags: AC ios
Is this bug a regression?: ---
Last known good build:


Attachments
Project demonstrating feature (508.61 KB, application/zip)
2015-07-29 16:06 UTC, Eric Schmitz
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Eric Schmitz 2015-07-29 15:39:59 UTC
In the following scenario an iOS app will lose the tint color in toolbar items and in the tabpage icons:

1) Application is started in simulator or on device.
2) DisplayAlert() dialog box is presented.
3) Home button pressed without dismissing dialog.
4) Code in override OnSleep() sets MainPage = new SomeOtherPage();
5) App is restored, main page is restored in override OnStart(); tint color is lost and items are rendered as grey.

Sample attached.
Comment 1 Eric Schmitz 2015-07-29 16:06:40 UTC
Created attachment 12288 [details]
Project demonstrating feature
Comment 2 adrianknight89 2016-10-12 06:02:58 UTC
This issue does not exist in 2.3.3.152-pre2. Can you confirm?