Bug 32465 - SIGABRT: Error in `/usr/bin/mono': double free or corruption (fasttop): 0x00007f3e280da8a0
Summary: SIGABRT: Error in `/usr/bin/mono': double free or corruption (fasttop): 0x000...
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: GC ()
Version: 4.0.0
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-07-27 08:05 UTC by Bartosz Kukawka
Modified: 2016-11-28 15:51 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Bartosz Kukawka 2015-07-27 08:05:05 UTC
Unfortunately I cannot produce a test case, crashes happen randomly when under moderate load.

*** Error in `/usr/bin/mono': double free or corruption (fasttop): 0x00007f3e280da8a0 ***
Stacktrace:
at <unknown> <0xffffffff> 
at (wrapper managed-to-native) object.__icall_wrapper_mono_gc_alloc_string (intptr,intptr,int) <0xffffffff> 
at (wrapper alloc) object.AllocString (intptr,int) <0xffffffff> 
at System.Text.StringBuilder.InternalEnsureCapacity (int) <0x000bb> 
at System.Text.StringBuilder.Append (char) <0x00047> 
at NHibernate.Linq.Visitors.ExpressionKeyVisitor.VisitMethod (System.Reflection.MethodInfo) <0x0017f> 
at NHibernate.Linq.Visitors.ExpressionKeyVisitor.VisitMethodCallExpression (System.Linq.Expressions.MethodCallExpression) <0x00149> 
at Remotion.Linq.Parsing.ExpressionTreeVisitor.VisitExpression (System.Linq.Expressions.Expression) <0x00291> 
at NHibernate.Linq.Visitors.ExpressionKeyVisitor.Visit (System.Linq.Expressions.Expression,System.Collections.Generic.IDictionary`2<System.Linq.Expressions.ConstantExpression, NHibernate.Param.NamedParameter>) <0x00057> 
at NHibernate.Linq.NhLinqExpression..ctor (System.Linq.Expressions.Expression,NHibernate.Engine.ISessionFactoryImplementor) <0x00245> 
(...)

Native stacktrace:
/usr/bin/mono() [0x4b20bc]
 /lib/x86_64-linux-gnu/libpthread.so.0(+0x10340) [0x7f3a5dd90340]
 /lib/x86_64-linux-gnu/libc.so.6(gsignal+0x39) [0x7f3a5d9f1cc9]
 /lib/x86_64-linux-gnu/libc.so.6(abort+0x148) [0x7f3a5d9f50d8]
 /usr/bin/mono() [0x6294f9]
 /usr/bin/mono() [0x629707]
 /usr/bin/mono() [0x629856]
 /usr/bin/mono() [0x541a3d]
 /usr/bin/mono() [0x422173]
 /usr/bin/mono() [0x5a6ba2]
 /usr/bin/mono() [0x5b02b0]
 /usr/bin/mono() [0x5a1929]
 /usr/bin/mono() [0x5a1960]
 /usr/bin/mono() [0x5a1dfd]
 /usr/bin/mono() [0x587188]
 /usr/bin/mono() [0x6236c6]
 /lib/x86_64-linux-gnu/libpthread.so.0(+0x8182) [0x7f3a5dd88182]
 /lib/x86_64-linux-gnu/libc.so.6(clone+0x6d) [0x7f3a5dab547d]
 
Debug info from gdb:

=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

OS:
Ubuntu 14.04 x86_64 (3.13.0-55-generic)

Mono version:
Mono JIT compiler version 4.0.2 (Stable 4.0.2.5/c99aa0c Wed Jun 24 10:04:37 UTC
2015)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors.
www.mono-project.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  amd64
        Disabled:      none
        Misc:          softdebug
        LLVM:          supported, not enabled.
        GC:            sgen
Comment 1 Vlad Brezae 2016-11-08 22:53:54 UTC
Hello

     Is this still occurring with latest mono releases ?

Vlad
Comment 2 Bartosz Kukawka 2016-11-17 10:37:45 UTC
Hi,

no, the problem seems to be resolved. It happened last time more than 2 months ago, probably on Mono 4.4.1.

Bartek
Comment 3 Vlad Brezae 2016-11-28 15:51:38 UTC
Marking as resolved as indicated by above comment.