Bug 3240 - Unhandled exception when choosing emulator from device list and hitting ok before emulator has fully loaded
Summary: Unhandled exception when choosing emulator from device list and hitting ok be...
Status: RESOLVED DUPLICATE of bug 860
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-02-06 13:28 UTC by PJ
Modified: 2016-08-03 15:25 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 860

Description PJ 2012-02-06 13:28:29 UTC
I am getting an unhandled exception with an un-copy/paste-able error message when I deploy to emulator. This happens if I select the emulator from the device list when it appears (as opposed to waiting a while for the emulator to fully load).

Picture of error message:
http://screencast.com/t/wqPxI1bL

Steps to reproduce:
1) Open VS, create new MfA application project.
2) Debug.
3) When device window appears, start an emulator.
4) When emulator appears on select device window, select the emulator and hit ok.
5) Wait for error.



MfA 4.0.3 eval
Comment 1 PJ 2012-02-06 13:29:07 UTC
VS 2010
Windows 7
Comment 2 PJ 2012-02-06 13:57:30 UTC
I now got past the point of the crash after using the chainer to add additional Android SDKs (not sure how this is affecting it, because I'm still using the API lvel 8 AVD).

I will restore snapshot and see if there was an issue with my AVD from before I did this.

Emulator is taking upwards of 10m to load a package, making this hard to nail down.
Comment 3 Jonathan Pobst 2012-02-06 14:35:03 UTC
That's a standard Windows dialog box, you can press Ctrl-C to copy the contents of it.

This bug should already be fixed for 4.2.

*** This bug has been marked as a duplicate of bug 860 ***