Bug 32362 - MT3001: Could not AOT the assembly
Summary: MT3001: Could not AOT the assembly
Status: RESOLVED DUPLICATE of bug 26699
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 8.10
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-07-23 10:44 UTC by Prashant Cholachagudda
Modified: 2015-07-24 16:53 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Build log (78.31 KB, text/rtf)
2015-07-23 10:44 UTC, Prashant Cholachagudda
Details
Crash log from arm64-darwin-mono-sgen (26.58 KB, application/octet-stream)
2015-07-23 12:56 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 26699

Description Prashant Cholachagudda 2015-07-23 10:44:45 UTC
Created attachment 12185 [details]
Build log

This is rather strange bug!

Customer has latest installation of Xamarin tools. However all Xamarin.iOS (new and existing) are falling to build with following error:

	MTOUCH: error MT3001: Could not AOT the assembly '/Users/PicturePresent/Projects/test/iOS/obj/iPhone/Release/mtouch-cache/64/Build/test.iOS.exe'

Full build log is attached.
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2015-07-23 12:56:51 UTC
Created attachment 12189 [details]
Crash log from arm64-darwin-mono-sgen

It appears that `arm64-darwin-mono-sgen` crashes on launch on this user's machine.



For example, if he attempts to run it from the command line in Terminal.app ...

> /Library/Frameworks/Xamarin.iOS.framework/Versions/8.10.3.2/bin/arm64-darwin-mono-sgen



... it crashes at:

> Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
> 0   libsystem_c.dylib             	0x00007fff8e376152 strlen + 18
> 1   arm64-darwin-mono-sgen        	0x0000000100265f44 0x1001f0000 + 483140
> 2   libdyld.dylib                 	0x00007fff9073f5c9 start + 1
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2015-07-23 13:06:30 UTC
For comparison, the non-cross-compiled Mono binaries run without error on the user's machine.

- `/usr/bin/mono --version`
- `/usr/bin/mono-sgen --version`