Bug 323 - Console Output is not visible with MonoTouch 4.1
Summary: Console Output is not visible with MonoTouch 4.1
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: 4.x
Hardware: PC Linux
: --- critical
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-08-18 09:55 UTC by Miguel de Icaza [MSFT]
Modified: 2014-03-27 09:49 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Miguel de Icaza [MSFT] 2011-08-18 09:55:14 UTC
And MonoDevelop 2.6 RC1.

Adding Console.WriteLine does not show up on the "Application Output" window.
Comment 1 Mikayla Hutchinson [MSFT] 2011-08-18 19:30:13 UTC
Run or debug, simulator or device?

For device, we can only shown console output using the debugger's directed stdout/stderr, so I would guess a regression caused by USB debugging support.
Comment 2 Miguel de Icaza [MSFT] 2011-08-19 21:22:13 UTC
I believe Chris Toshok fixed this already.
Comment 3 Saurabh 2014-03-27 09:49:21 UTC
I have checked issue with latest master builds.

Now, I am getting console output in XS output window on running application.

Screencast: http://screencast.com/t/0QrifqilPrY

=== Xamarin Studio ===

Version 4.2.4 (build 266)
Installation UUID: b1fc3b76-cf00-405e-a0a1-3839ac11fe6d
Runtime:
	Mono 3.2.6 ((no/9b58377)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 302060000

=== Apple Developer Tools ===

Xcode 5.0 (3332.22)
Build 5A1412

=== Xamarin.iOS ===

Version: 7.2.2.14 (Enterprise Edition)
Hash: 16bef0b
Branch: 
Build date: 2014-03-20 12:01:19-0400

=== Build Information ===

Release ID: 402040266
Git revision: 57fa6b7639703775ae1d5c46536e42ab424cb177
Build date: 2014-03-20 12:34:27-04
Xamarin addins: eee141c29724a19529e77b8e743086d95b29f5ba

=== Operating System ===

Mac OS X 10.9.3
Darwin Apples-iMac.local 13.2.0 Darwin Kernel Version 13.2.0
    Tue Mar 11 22:16:58 PDT 2014
    root:xnu-2422.100.4~2/RELEASE_X86_64 x86_64


Hence, closing this issue.