Bug 32182 - TabbedPage CarouselPage: Appearing and Disappearing not raised consistantly
Summary: TabbedPage CarouselPage: Appearing and Disappearing not raised consistantly
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.3
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-07-21 04:42 UTC by Michael Rumpler
Modified: 2016-04-11 08:57 UTC (History)
5 users (show)

Tags: TabbedPage CarouselPage Appearing Disappearing ac
Is this bug a regression?: ---
Last known good build:


Attachments
sample project (314.10 KB, application/x-zip-compressed)
2015-07-21 04:42 UTC, Michael Rumpler
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Michael Rumpler 2015-07-21 04:42:38 UTC
Created attachment 12128 [details]
sample project

Page.Appearing and Disappearing are not raised consistently when switching between subpages of a TabbedPage or a CarouselPage.

I created a solution for all platforms with this simple code:

        public App()
        {
		var tp = new TabbedPage();

		tp.Children.Add(CreatePage("Page 1"));
		tp.Children.Add(CreatePage("Page 2"));
		tp.Children.Add(CreatePage("Page 3"));

		MainPage = tp;
        }

Here are the results of my tests:

Android:
OK (Appearing for the page which appears, on switch: Disappearing for old page followed by Appearing for new)

iOS:
OK (Appearing for the page which appears, on switch: Disappearing for old page followed by Appearing for new)

WinPhone SL:
Appearing raised for all pages at once, Disappearing is not raised at all

WinRT.Phone:
Appearing is raised when a page comes up the first time but not later, Disappearing is not raised at all

WinRT.Tablet:
OK (Appearing for the page which appears, on switch: Disappearing for old page followed by Appearing for new)


If you set tp to a new CarouselPage instead, then all platforms behave consistently, but wrong. All subpages raise Appearing at once before you even switched pages. Disappearing is not raised at all.


My sample project is in Xamarin.Forms.1.4.3.6376. I also tried this with 1.4.4.6379-pre3, but there the Windows (WinRT.Tablet) project won't start at all.


There are various other bugs regarding Appearing/Disappearing, but none exactly about the issues described here.
https://bugzilla.xamarin.com/show_bug.cgi?id=29330 reports inconsistent behavior on a CarouselPage which I cannot confirm
https://bugzilla.xamarin.com/show_bug.cgi?id=27798 inconsistent order of Appearing/Disappearing
https://bugzilla.xamarin.com/show_bug.cgi?id=26479 Appearing/Disappearing when doing PushModalAsync/PopModalAsync
https://bugzilla.xamarin.com/show_bug.cgi?id=28242 Disappearing on CarouselPage on Android

Bug 28242 is set to FIXED VERIFIED in version 1.4.3-pre1, but I still see the wrong behavior in 1.4.3.6376.
Comment 1 Parmendra Kumar 2015-07-21 06:29:48 UTC
I have checked this issue and observed that Appearing raised for all pages at once, Disappearing is not raised at all on WinPhone.

Screencast: http://www.screencast.com/t/gLQicaV4R8yq

Applicationoutput Log: https://gist.github.com/Parmendrak/d2c7ac5f6316356e81f9
IDE Log: https://gist.github.com/Parmendrak/0a88dcbb153e42a10cf0

Environment info:

Xamarin.Forms.1.4.4.6379-pre3

Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.51641
Xamarin   3.11.666.0 
Xamarin.Android   5.1.4.16 
Xamarin.iOS   8.10.2.0
Comment 2 Jason Smith [MSFT] 2016-04-11 08:57:04 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team