Bug 32152 - StackLayout FillAndExpand not expanding
Summary: StackLayout FillAndExpand not expanding
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.4
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-07-20 13:29 UTC by John Miller [MSFT]
Modified: 2016-04-11 08:55 UTC (History)
6 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Test Case (177.28 KB, application/zip)
2015-07-20 13:29 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Miller [MSFT] 2015-07-20 13:29:50 UTC
Created attachment 12116 [details]
Test Case

**Overview:**

   StackLayout is not expanding under certain conditions when FillAndExpand is used. 

**Steps to Reproduce:**

   1. Run the attached sample on iOS simulator

**Actual Results:**

   1. Portrait: http://screencast.com/t/PzGby78bw
   2. Landscape: http://screencast.com/t/bro1zA9kKUb

**Expected Results:**

   In portrait, there is some extra space at the end of the layout that is expected to be filled with the StackLayout that is marked with FillAndExpand. http://screencast.com/t/LEAn0qjFvh33 It is expected that the Lime green layout be expanding into this space.

   In Landscape, you can see better results for the first two layouts. However, the third layout (marked with orange arrow) still has some space at the end that is not being used by the StackLayout: http://screencast.com/t/oXb09CZJ It is expected that the Lime green layout be expanding into this space.

**Build Date & Platform:**

   XF 1.4.4-pre2

**Additional Information:**

   I tried different layout options and I am not able to replicate a layout as expected. The nested StackLayout does not consume (expand) the space I want it to.
Comment 1 Chris King 2015-07-22 16:25:30 UTC
On IPhone 4S simulator the middle element has an aqua element that is expected to be centered in the yellow element but is right justified instead.
Comment 2 Ram Chandra 2015-08-10 08:46:37 UTC
I have checked this issue with attached sample and I am also getting the reported behavior.

I observed that the FillAndExpand is not working for StackLayout. There is some extra space in portrait and Landscape mode.

Screencast: http://www.screencast.com/t/Ym45ZwYw7E
IDE logs:  https://gist.github.com/RamChBachkheti/0905020e7893fcf063df

I have also checked this with android and on android it is working fine for portrait mode but failed for landscape mode.

Environment Info: 

Xamarin.Forms:  1.5.0.6396-pre1

=== Xamarin Studio ===

Version 5.9.5 (build 9)
Installation UUID: 6ea47b0d-1852-4aaf-808d-373ff0a5002b
Runtime:
	Mono 4.0.3 ((detached/d6946b4)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400030020

=== Xamarin.Android ===

Version: 5.1.3.1 (Business Edition)
Android SDK: /Users/jatin66/Desktop/Backup/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 6.4 (7720)
Build 6E35b

=== Xamarin.iOS ===

Version: 8.10.4.49 (Business Edition)
Hash: 7e598ef
Branch: master
Build date: 2015-08-08 12:28:27-0400

=== Xamarin.Mac ===

Version: 2.0.2.125 (Business Edition)

=== Build Information ===

Release ID: 509050009
Git revision: b99cb19a1d3b15d8980c4616f13f837457e5b292
Build date: 2015-07-28 02:01:44-04
Xamarin addins: d53d6eceb828422f3d4aff8547f2f6bab6c9ea58

=== Operating System ===

Mac OS X 10.10.3
Darwin Dalvik.local 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 3 Jason Smith [MSFT] 2016-04-11 08:55:42 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team