Bug 32130 - Parenthesis around elvis operators do not resolve to nullable
Summary: Parenthesis around elvis operators do not resolve to nullable
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: 4.0.0
Hardware: All All
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2015-07-20 04:58 UTC by Martijn Laarman
Modified: 2015-07-20 12:43 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Martijn Laarman 2015-07-20 04:58:42 UTC
The following does not work on the alpha channel in xamarin

(myobject?.myEnumerable?.Any()).GetValueOrDefault(false)

It does not detect that whats inside of the parenthesis is actually a Nullable<bool>. It gets picked up as bool. 

If I assign whats inside of the parenthesis to a var the nullable type is however inferred properly.
Comment 1 Marek Safar 2015-07-20 12:43:22 UTC
Fixed in master and Mono 4.2