Bug 3211 - Race condition when XmlAnyElement is applied to a XmlNode field.
Summary: Race condition when XmlAnyElement is applied to a XmlNode field.
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.XML ()
Version: 2.10.x
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: marcos.henrich
URL:
Depends on:
Blocks:
 
Reported: 2012-02-02 17:18 UTC by Tom Hindle
Modified: 2014-08-26 04:17 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test case Serializing an object 10000 times. (1.04 KB, text/x-csharp)
2012-02-02 17:18 UTC, Tom Hindle
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Tom Hindle 2012-02-02 17:18:08 UTC
Created attachment 1309 [details]
Test case Serializing an object 10000 times.

This is a minor issues as it can be worked around by changing XmlNode to XmlElement.


Test case throws the following error:

nhandled Exception: System.InvalidOperationException: There was an error generating the XML document. ---> System.InvalidOperationException: The XML element named 'SomeElement' from namespace '' was not expected. The XML element name and namespace must match those provided via XmlAnyElementAttribute(s).
at Mono.GeneratedSerializers.Literal.GeneratedWriter.WriteObject_Comment
at Mono.GeneratedSerializers.Literal.GeneratedWriter.WriteObject_CommentThread
at Mono.GeneratedSerializers.Literal.GeneratedWriter.WriteRoot_CommentThread


If test case isn't throwing error try increasing loop value 10000 to something bigger.
Comment 1 marcos.henrich 2014-08-22 06:55:30 UTC
Hi Tom,

Thank you for the detailed bug report.

The pull request for this issue can be found in the link below.
https://github.com/mono/mono/pull/1223
Comment 2 marcos.henrich 2014-08-26 04:17:22 UTC
Fixed in master 78b1cde8fcfd459a59d25e8ec4e8d3022fc29d8e.

https://github.com/mono/mono/commit/78b1cde8fcfd459a59d25e8ec4e8d3022fc29d8e