Bug 32033 - WebView on Windows does not display local HTML files
Summary: WebView on Windows does not display local HTML files
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 1.4.4
Hardware: PC Windows
: Normal enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-07-16 12:24 UTC by John Hardman
Modified: 2016-08-12 19:32 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description John Hardman 2015-07-16 12:24:17 UTC
No matter what I try, I cannot get WebView to display a local HTML file on Windows / WinRT. It works for Android, iOS and WinPhone, but not for Windows.

I have asked for help on this on both the forums and by email direct to support, but with no useful response. Makes me think that I may be the first person to try this, or alternatively, others have tried but also without success. I am not 100% certain that this is a bug, but as per instruction from support, am raising it as a bug for Xamarin to investigate.
Comment 1 Paul DiPietro [MSFT] 2015-08-25 12:24:08 UTC
Per the documentation viewable here:

http://developer.xamarin.com/guides/cross-platform/xamarin-forms/user-interface/webview/#Windows_Phone

It is stated that local HTML files do not work with WebView on 8.1, but do on 8.0. For the moment I will set this to confirmed, although it would be considered an enhancement.
Comment 2 Jason Smith [MSFT] 2016-04-11 07:42:00 UTC
Thank you for taking the time to submit this feature request. We like this idea and have added it to our internal feature tracking system.

Warm regards,
Xamarin Forms Team
Comment 3 Parmendra Kumar 2016-08-12 19:32:08 UTC
I have checked this issue with Xamarin.Forms 2.3.2-pre1 and observed that local HTML files works fine with WebView on 8.1
To verify this issue I have used forms sample "WorkingWithWebview".

Hence closing this issue.

Thanks.