Bug 31973 - Password Box does not show input - Windows Phone
Summary: Password Box does not show input - Windows Phone
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-07-15 11:41 UTC by Brian
Modified: 2015-07-16 17:16 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Example (196.58 KB, application/octet-stream)
2015-07-15 11:50 UTC, Brian
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Brian 2015-07-15 11:41:36 UTC
Windows phone password entry is not showing character input.

Attached sample project.
Comment 1 Brian 2015-07-15 11:50:29 UTC
Created attachment 12044 [details]
Example
Comment 2 Brian 2015-07-15 12:21:34 UTC
here is a work around.

Add a renderer and set the Password box Text to the Element Text.



 protected override void OnElementPropertyChanged(object sender, PropertyChangedEventArgs e)
        {
            base.OnElementPropertyChanged(sender, e);


           
            if (e.PropertyName == "Text" && Element.IsPassword)
            {

                var _passwordBox = (PasswordBox)Control.Children[1];
                _passwordBox.Password = Element.Text;

            }
        }
Comment 3 Adam 2015-07-16 00:21:22 UTC
I am also experiencing this issue.
Comment 4 Jason Smith [MSFT] 2015-07-16 17:16:38 UTC
Should be fixed in 1.4.4-pre2