Bug 31923 - Xamarin Studio not hitting the breakpoints
Summary: Xamarin Studio not hitting the breakpoints
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: 5.2
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-07-14 09:57 UTC by David Petrík
Modified: 2015-08-12 11:23 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description David Petrík 2015-07-14 09:57:15 UTC
Hello,

Xamarin Studio not hitting the breakpoints after upgrade.



Xamarin Studio
Version 5.9.4 (build 5)
Installation UUID: cd710af9-c0e2-4628-9165-8a7c6f81acf0
Runtime:
 Microsoft .NET 4.0.30319.34209
 GTK+ 2.24.22 (MS-Windows theme)
 GTK# 2.12.26

Xamarin.Android
Version: 5.1.4 (Indie Edition)
Android SDK: c:\Users\kovanda\AppData\Local\Android\android-sdk
 Supported Android versions:
  2.3   (API level 10)
  4.0.3 (API level 15)
  4.1   (API level 16)
  4.2   (API level 17)
  4.3   (API level 18)
  4.4   (API level 19)
  5.0   (API level 21)
Java SDK: C:\Program Files\Java\jdk1.7.0_71
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Xamarin Android Player
Not Installed

Build Information
Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 17:16:25-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

Operating System
Windows 6.2.9200.0 (64-bit)
Comment 1 Sadik Ali 2015-08-12 08:13:08 UTC
I have checked this issue and unable to reproduce the reported behavior given in the bug description. Breakpoint getting hit successfully.

Screencast: http://www.screencast.com/t/I1VTkNF3pZqy

Please let me know if I missed any step

It would be great if you provide Ide Logs, Application Output, Build Output,Screencast and Sample application to reproduce the above behavior.

You can get these information from the following:

Ide Logs: Help >> Open Log Directory
Application Output: View >> Pads >> Application Output

Environment Info:

=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: c13e6eeb-f876-4a06-8631-6289a6546550
Runtime:
	Microsoft .NET 4.0.30319.18408
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

=== Xamarin.Android ===

Version: 5.1.5 (Starter Edition)
Android SDK: C:\Users\Abhinav\AppData\Local\Android\android-sdk
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: C:\Program Files\Java\jdk1.7.0_71
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) Client VM (build 24.71-b01, mixed mode, sharing)

=== Xamarin Android Player ===

Version: 0.3.4
Location: C:\Program Files\Xamarin Android Player\DeviceManager.exe

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 17:16:25-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Windows 6.1.7601.65536
Comment 2 David Petrík 2015-08-12 11:23:13 UTC
Hello,
this problem was fixed in version Xamarin.Android 5.1.5

David