Bug 31856 - ListView incorrect formatting of group headers and items
Summary: ListView incorrect formatting of group headers and items
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 1.4.3
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Stephane Delcroix
URL:
Depends on:
Blocks:
 
Reported: 2015-07-11 22:50 UTC by Franc
Modified: 2015-08-06 13:41 UTC (History)
5 users (show)

Tags: AC
Is this bug a regression?: ---
Last known good build:


Attachments
project showing the bug (27.55 KB, application/zip)
2015-07-15 02:07 UTC, Franc
Details
screenshot (24.57 KB, image/jpeg)
2015-07-15 02:09 UTC, Franc
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Franc 2015-07-11 22:50:47 UTC
Formatting is incorrect if using custom templates for both the group header and the items. Specifically, regular items will take on some of the properties of the header and vice versa (font size, color, etc).

To Reproduce use the exact code as show in...

http://developer.xamarin.com/guides/cross-platform/xamarin-forms/working-with/listview/#grouping

...but with custom templates for the group header and the items. It is implied that the custom templates are different for group header and regular items.

Minimum API 15, testing in both simulator and device API 16. Have only tested Android.

Thank you
Comment 1 Chris King 2015-07-14 14:13:49 UTC
Thank you for taking the time to submit the bug. We tried to reproduce the issue you reported but were unable given the description. If you could please attach a reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue we would very much appreciate it.

Warm regards,
Xamarin Forms Team
Comment 2 Franc 2015-07-15 02:07:50 UTC
Created attachment 12029 [details]
project showing the bug

project showing the bug
Comment 3 Franc 2015-07-15 02:09:29 UTC
Created attachment 12030 [details]
screenshot
Comment 4 Franc 2015-07-17 21:05:51 UTC
See sample project and screenshot.
Comment 5 Jason Smith [MSFT] 2015-07-27 14:11:55 UTC
Should be fixed in 1.4.5-pre1
Comment 6 Parmendra Kumar 2015-08-06 13:41:05 UTC
I have checked this issue with X.F 1.5.0-pre1 and its working fine at my end.

Hence closing this issue.


Thanks.