Bug 31820 - Problemas com Newtonsoft.Json
Summary: Problemas com Newtonsoft.Json
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-07-10 08:06 UTC by Wendel
Modified: 2016-12-22 21:10 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Wendel 2015-07-10 08:06:23 UTC
O erro que e mostrado no meu Error List e o seguinte.
====================================================================================================================
Error	3	Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.IO.FileNotFoundException: Could not load assembly 'Newtonsoft.Json, Version=, Culture=neutral, PublicKeyToken='. Perhaps it doesn't exist in the Mono for Android profile?	WebRequests
====================================================================================================================

Segui a recomendação que me foi dito, ainda continua dando erro,disseram que eu deveria mudar de utf-8 characters para US-ASCII que iria resolver, mais não deu certo.

se alguém poder me ajudar.
Comment 1 Ram Chandra 2015-08-18 07:01:10 UTC
I have checked this issue but I am not able to reproduce this issue.

Steps I followed:
1. Create an android application
2. Install the latest Newtonsoft.Json package
3. Write the following code in MainActivity:

    JArray array = new JArray();
    array.Add("Manual text");
    array.Add(new DateTime(2000, 5, 23));
    JObject o = new JObject();
    o["MyArray"] = array;

4. Build and deploy the solution.

I am successfully able to build the solution without any error/exception.

If you have a chance, it might also be helpful to provide test steps to reproduce this issue, IDE logs and build info. 

You can get build info from here:
Visual Studio => HELP => About Microsoft Visual Studio => Copy Info

You can get IDE logs from here:
Visual Studio => HELP => Xamarin => Zip logs

Environment Info: 

Windows 8
Json.NET 7.0.1

Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.50938
Installed Version: Professional
Xamarin   3.11.836.0 (ed5c750)
Xamarin.Android   5.1.5.3 (f98871a95a479f6d71b3067b7e5834d41fcb2118)
Xamarin.iOS   8.10.4.0 (6db87c53c073f4af2f5247fb738a27ea08c094fd)
Comment 2 Jose Gallardo 2016-12-22 21:10:36 UTC
Hi,
I'll mark the bug as resolved fixed (given some updates we've introduced since the bug was reported).
Please feel free to reopen it if you can still reproduce the issue with current bits.
Thanks!