Bug 31669 - SearchBar displays black background with BackgroundColor = Color.Transparent on iOS
Summary: SearchBar displays black background with BackgroundColor = Color.Transparent ...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 1.4.4
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2015-07-06 13:29 UTC by Timothy Risi
Modified: 2015-08-14 06:22 UTC (History)
3 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Repro (180.63 KB, application/zip)
2015-07-06 13:31 UTC, Timothy Risi
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Timothy Risi 2015-07-06 13:29:46 UTC
If you set the background color to another color it will show the selected color for the background.  If you set it to Transparent, it shows black instead of whatever color/image etc is behind the SearchBar.  In the sample app, backgorund color is set to red.  SearchBar has a black background, label shows the correct Red.

Tested on iOS and Android, iOS has the issue, Android correctly shows the BackGround color of the layout the searchbar is part of.  On a Mac right now so I can't test the WP version.
Comment 1 Timothy Risi 2015-07-06 13:31:13 UTC
Created attachment 11885 [details]
Repro
Comment 2 Rui Marinho 2015-07-30 06:48:58 UTC
Should be fixed in 1.4.5-pre1
Comment 3 Parmendra Kumar 2015-08-06 14:17:20 UTC
I have checked this issue with Xamarin.Forms 1.5.0-pre1 and I am still getting same behavior mentioned in bug description.

Screencast: http://www.screencast.com/t/ggKjlbTQf0eo

Hence reopen this issue.
Comment 4 Rui Marinho 2015-08-14 06:22:32 UTC
Yap sorry the pr wasn't merged.
Should be fixed in 1.5.0-pre2