Bug 31529 - MarkupExpression parser doesn't work with extra whitespaces
Summary: MarkupExpression parser doesn't work with extra whitespaces
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.4
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Stephane Delcroix
URL:
Depends on:
Blocks:
 
Reported: 2015-07-01 05:43 UTC by Stephane Delcroix
Modified: 2015-07-17 16:48 UTC (History)
4 users (show)

Tags: AC xaml
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Stephane Delcroix 2015-07-01 05:43:19 UTC

    
Comment 1 Stephane Delcroix 2015-07-01 05:44:28 UTC
this

<Button
                        Command = "{Binding DeleteCommand}"
                        CommandParameter = "{Binding SelectedItem, Source = {x:Reference listview}} "
                        BackgroundColor = "#F23545 "
                        FontSize = "20"
                        Text = "Delete"
                        TextColor = "White"/>

does not work, while this

<Button
                        Command = "{Binding DeleteCommand}"
                        CommandParameter = "{Binding SelectedItem, Source={x:Reference listview}}"
                        BackgroundColor = "#F23545 "
                        FontSize = "20"
                        Text = "Supprimez"
                        TextColor = "White"/>

does work fine.
Comment 2 Parmendra Kumar 2015-07-01 10:34:15 UTC
I have checked this issue and I am getting same behavior with Xamarin.Forms 1.3.4.6332.
But I am unable to reproduce this issue with Xamarin.Forms 1.4.3.6374.

Screencast: http://www.screencast.com/t/lLqCO50r5QX

Please check the screencast and let me know if I have missed anything. 

Thanks.
Comment 3 Stephane Delcroix 2015-07-06 09:07:38 UTC
@Parmendra: the screencast only shows the parsing doesn't crash, but doesn't proves the markup extension is evaluated correctly.
Comment 4 Parmendra Kumar 2015-07-06 10:24:42 UTC
Thanks @Stephane for clarification,

Could you please let me know what should I have to check for 'MarkupExpression parser doesn't work with extra whitespaces'?

Thanks.
Comment 5 Jason Smith [MSFT] 2015-07-08 05:00:58 UTC
Should be fixed in 1.4.4-pre1
Comment 7 Jason Smith [MSFT] 2015-07-17 16:48:58 UTC
Yeah it's fine :)