Bug 3147 - MonoDevelop syncing issue with XCode
Summary: MonoDevelop syncing issue with XCode
Status: RESOLVED DUPLICATE of bug 3067
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.8.6
Hardware: PC Mac OS
: --- major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-01-30 16:14 UTC by Eric Beisecker
Modified: 2012-01-30 16:38 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 3067

Description Eric Beisecker 2012-01-30 16:14:49 UTC
XCode seems to not sync Outlets and Actions added to the controller properly after Syncing back to MonoDevelop.

This can manifest its self as missing outlets and actions in the .h controller file or "old" versions of the .h file being displayed after switching between MonoDevelop and XCode.


Video Example: http://screencast.com/t/r2pTXmay7ZTJ

Explaination: I add a new Button to the .xib file and then add an outlet for it in the controller. I return to MonoDevelop, open the .Designer file, see the newly created property, Return to XCode and see my Outlet no longer exists in the controller File.


Versions:
MonoDevelop 2.8.6.3
Monotouch: 5.0.4
Comment 1 Jeffrey Stedfast 2012-01-30 16:38:02 UTC
I am so 1 step ahead of you ;-)

*** This bug has been marked as a duplicate of bug 3067 ***