Bug 3139 - Clean failed. Object reference not set to an instance of an object
Summary: Clean failed. Object reference not set to an instance of an object
Status: CLOSED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.8.6
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 3171 ()
Depends on:
Blocks:
 
Reported: 2012-01-30 10:39 UTC by Sebastien Pouliot
Modified: 2012-02-01 16:22 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description Sebastien Pouliot 2012-01-30 10:39:46 UTC
using MonoDevelop 2.8.6.4


Cleaning: VKWApp (Debug|iPhone)

Performing clean...

Clean complete

---------------------- Done ----------------------

Clean successful.
Clean failed. Object reference not set to an instance of an object
Comment 2 Jeffrey Stedfast 2012-01-30 15:19:45 UTC
Fixed in git master
Comment 3 Alan McGovern 2012-01-31 10:27:13 UTC
Just to explain exactly what was wrong:

1) Create a MonoTouch project
2) Add a new Library project
3) Add some xib files to the Library project
4) Build.

Result: A null reference exception is thrown when compiling/cleaning/whatever.

This was caused by MonoDevelop trying to open an Info.plist file in the Library project which normally does not contain one.
Comment 4 PJ 2012-01-31 12:27:06 UTC
Fix is in the current beta 2.8.6.4

Closing.
Comment 5 Jeffrey Stedfast 2012-02-01 15:22:19 UTC
Actually, this problem was caused by a custom build command with an empty executable field value.

Also, the patch wasn't backported to 2.8.6.4, so this shouldn't be fixed unless someone else backported it.
Comment 6 Jeffrey Stedfast 2012-02-01 15:27:46 UTC
commit 9c0bec56bf727f46afae68cd009f376ec76ec004
Author: Jeffrey Stedfast <jeff@xamarin.com>
Date:   Mon Jan 30 15:18:46 2012 -0500

    [Core] Fixed custom command execution to sanity check user input
    
    Fixes bug #3139.



This patch is only on master, not the 2.8.6 branch.

You guys are probably thinking of my fix for bug #3042
Comment 7 Jeffrey Stedfast 2012-02-01 16:22:30 UTC
*** Bug 3171 has been marked as a duplicate of this bug. ***