Bug 3130 - [sdb] Debugger claims the runtime is not pasued
Summary: [sdb] Debugger claims the runtime is not pasued
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger ()
Version: 2.10.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2012-01-29 10:58 UTC by Alan McGovern
Modified: 2015-02-20 12:10 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alan McGovern 2012-01-29 10:58:45 UTC
I can reliably trigger this issue by single stepping through the 'TestIterator_MissingUnresolvedSymbolicRefIsBug' unit test in ngit when debugging with mono 2.10.8.1 and monodevelop master:

System.InvalidOperationException: The vm is not suspended.
  at Mono.Debugger.Soft.VirtualMachine.ErrorHandler (System.Object sender, Mono.Debugger.Soft.ErrorHandlerEventArgs args) [0x0004d] in /Users/alanmcgovern/Projects/monodevelop/main/contrib/Mono.Debugger.Soft/Mono.Debugger.Soft/VirtualMachine.cs:282 
  at Mono.Debugger.Soft.Connection.SendReceive (CommandSet command_set, Int32 command, Mono.Debugger.Soft.PacketWriter packet) [0x000d5] in /Users/alanmcgovern/Projects/monodevelop/main/contrib/Mono.Debugger.Soft/Mono.Debugger.Soft/Connection.cs:1394 
  at Mono.Debugger.Soft.Connection.Thread_GetFrameInfo (Int64 id, Int32 start_frame, Int32 length) [0x00000] in /Users/alanmcgovern/Projects/monodevelop/main/contrib/Mono.Debugger.Soft/Mono.Debugger.Soft/Connection.cs:1735 
  at Mono.Debugger.Soft.ThreadMirror.GetFrames () [0x00000] in /Users/alanmcgovern/Projects/monodevelop/main/contrib/Mono.Debugger.Soft/Mono.Debugger.Soft/ThreadMirror.cs:18 
  at Mono.Debugging.Soft.SoftDebuggerBacktrace..ctor (Mono.Debugging.Soft.SoftDebuggerSession session, Mono.Debugger.Soft.ThreadMirror thread) [0x0002c] in /Users/alanmcgovern/Projects/monodevelop/main/src/addins/MonoDevelop.Debugger.Soft/Mono.Debugging.Soft/SoftDebuggerBacktrace.cs:50 
  at (wrapper remoting-invoke-with-check) Mono.Debugging.Soft.SoftDebuggerBacktrace:.ctor (Mono.Debugging.Soft.SoftDebuggerSession,Mono.Debugger.Soft.ThreadMirror)
  at Mono.Debugging.Soft.SoftDebuggerSession.GetThreadBacktrace (Mono.Debugger.Soft.ThreadMirror thread) [0x00000] in /Users/alanmcgovern/Projects/monodevelop/main/src/addins/MonoDevelop.Debugger.Soft/Mono.Debugging.Soft/SoftDebuggerSession.cs:673 
  at Mono.Debugging.Soft.SoftDebuggerSession.OnGetThreadBacktrace (Int64 processId, Int64 threadId) [0x00000] in /Users/alanmcgovern/Projects/monodevelop/main/src/addins/MonoDevelop.Debugger.Soft/Mono.Debugging.Soft/SoftDebuggerSession.cs:668 
  at Mono.Debugging.Client.DebuggerSession.GetBacktrace (Int64 processId, Int64 threadId) [0x00011] in /Users/alanmcgovern/Projects/monodevelop/main/src/core/Mono.Debugging/Mono.Debugging.Client/DebuggerSession.cs:937 
  at Mono.Debugging.Client.ThreadInfo.get_Backtrace () [0x0000b] in /Users/alanmcgovern/Projects/monodevelop/main/src/core/Mono.Debugging/Mono.Debugging.Client/ThreadInfo.cs:79 
  at Mono.Debugging.Client.ThreadInfo.get_Location () [0x0000b] in /Users/alanmcgovern/Projects/monodevelop/main/src/core/Mono.Debugging/Mono.Debugging.Client/ThreadInfo.cs:64 
  at MonoDevelop.Debugger.ThreadsPad.AppendThreads (TreeIter it, Mono.Debugging.Client.ProcessInfo p) [0x00091] in /Users/alanmcgovern/Projects/monodevelop/main/src/addins/MonoDevelop.Debugger/MonoDevelop.Debugger/ThreadsPad.cs:174 
  at MonoDevelop.Debugger.ThreadsPad.UpdateDisplay () [0x00035] in /Users/alanmcgovern/Projects/monodevelop/main/src/addins/MonoDevelop.Debugger/MonoDevelop.Debugger/ThreadsPad.cs:146
Comment 1 Zoltan Varga 2012-01-30 04:56:31 UTC
How can I reproduce this ? Where is ngit ?
Comment 2 Zoltan Varga 2012-01-30 05:15:27 UTC
With master, I get:

Mono.Debugging.Evaluation.EvaluatorException: System.InvalidOperationException: Operation is not valid due to the current state of the object
  at Mono.Debugging.Soft.MethodCall.get_ReturnValue () [0x00029] in /home/zovarga/git/md/main/src/addins/MonoDevelop.Debugger.Soft/Mono.Debugging.Soft/SoftDebuggerAdaptor.cs:1292 
  at Mono.Debugging.Soft.SoftEvaluationContext.RuntimeInvoke (Mono.Debugger.Soft.MethodMirror method, System.Object target, Mono.Debugger.Soft.Value[] values) [0x00114] in /home/zovarga/git/md/main/src/addins/MonoDevelop.Debugger.Soft/Mono.Debugging.Soft/SoftEvaluationContext.cs:133
Comment 3 Jeffrey Stedfast 2015-02-20 12:10:36 UTC
assuming fixed