Bug 31287 - Re-ordering cells containing a FillAndExpand control in a ListView can cause one cell to not redisplay correctly on Android
Summary: Re-ordering cells containing a FillAndExpand control in a ListView can cause ...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 1.4.4
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-06-22 10:42 UTC by Trevor Prinn
Modified: 2017-01-06 19:16 UTC (History)
3 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Test app to demonstrate the problem (17.28 KB, application/x-zip)
2015-06-22 10:42 UTC, Trevor Prinn
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Trevor Prinn 2015-06-22 10:42:04 UTC
Created attachment 11705 [details]
Test app to demonstrate the problem

The attached project displays a list view with several items in custom cells. These cells contain a label and 2 buttons to re-order the cells by moving one within the ObservableCollection that is the ListView's ItemsSource. When the buttons are pressed, one cell will commonly redisplay without the buttons, and the label appears to be taking up the entire cell.
Comment 1 Paul DiPietro [MSFT] 2015-08-20 13:29:41 UTC
I can see what you're referring to in the Android implementation. I haven't tested it against WP but it seems to work as expected in iOS while using Forms 1.4.4.
Comment 2 Jimmy [MSFT] 2017-01-06 19:16:44 UTC
I was able to reproduce the original issue with Forms 1.4.2. However after updating to 2.3.3.180 the issue appears to be fixed.