Bug 31238 - [WinPhone] ListView Renderer Crashing with large list and ItemTemplate
Summary: [WinPhone] ListView Renderer Crashing with large list and ItemTemplate
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.3
Hardware: PC Windows
: Normal critical
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-06-18 19:26 UTC by James
Modified: 2016-04-10 02:04 UTC (History)
8 users (show)

Tags: ac listview crash windows 8.1
Is this bug a regression?: ---
Last known good build:


Attachments
Sample Project showing the issue (36.87 KB, application/zip)
2015-06-18 19:26 UTC, James
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description James 2015-06-18 19:26:59 UTC
Created attachment 11673 [details]
Sample Project showing the issue

When attempting to load a ListView of 1000 elements, on Windows Phone (Simulator or Device) The app crashes when you have more than 122 items.

Steps to reproduce

1. Open Sample Project
2. Run app
3. See crash
4. Comment out ItemTemplate code in TestView.xaml.cs and it should run.

Version info:

Xamarin version:
 
Xamarin   3.11.590.0 (5160db7)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.
 
Xamarin.Android   5.1.3.1 (d419c934e6ce2113653ff4c40214e3a5d5a69440)
Visual Studio plugin to enable development for Xamarin.Android.
 
Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.
 
Xamarin.iOS   8.10.1.0 (fce006eae308515fc1eaf85fcc0f90699d9c7e8b)
Visual Studio extension to enable development for Xamarin.iOS.
 
Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified
 
Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration

Tested with Xamarin.Forms 1.4.2
Comment 1 James 2015-06-18 19:27:47 UTC
I created a quick Android sample and also saw it had no problems loading the full 1,000 elements. This appears to be specific to rendering on Windows Phone.
Comment 2 Eder 2015-07-01 16:08:18 UTC
Also happening to me with just 23 items only on WP.

Follows my reported bug with sample:

https://bugzilla.xamarin.com/show_bug.cgi?id=31541
Comment 3 Parmendra Kumar 2015-08-04 08:21:07 UTC
I have checked this issue with attached sample project and I am also getting same behavior mentioned in bug description.

Screencast: http://www.screencast.com/t/gIPYBfsm

BuildOutput: https://gist.github.com/Parmendrak/62bfd2f1bd7a1380e308
IDE Log: https://gist.github.com/Parmendrak/72704fc284a543893717

Please let me know if I can provide anything else regarding the same.

Environment info:
Xamarin.Forms.1.4.4.6392
Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.51641
Installed Version: Professional
Xamarin   3.11.836.0 
Xamarin.Android   5.1.5.3 
Xamarin.iOS   8.10.4.0
Comment 4 andy.p.smart 2015-09-01 12:51:57 UTC
We're also hitting this issue. A ListView containing 12 or fewer items works as expected, but 13 or more will crash on Windows Phone. Running on Android the ListView can handle 100+ items with no problems.

This is a major issue and is stopping us from being able to release the app on Windows Phone.

Visual Studio Ultimate 2013 Update 4
Xamarin.Forms 1.4.4.6392
Comment 5 Kent Green [MSFT] 2015-09-08 19:15:12 UTC
Unless I'm mistaken, the sample in the description is actually for a Windows Desktop app, not a WinPhone app as the title currently implies. I have not determined if the exact same issue is occurring the same way in WinPhone.

I was also able to reproduce the issue in Xamarin.Forms 1.4.4.6392 based on the sample provided.
Comment 7 Jason Smith [MSFT] 2016-04-10 02:04:00 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team