Bug 31222 - Xamarin.iOS application shuts down without any crashlog on start profiling.
Summary: Xamarin.iOS application shuts down without any crashlog on start profiling.
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Tools ()
Version: 4.4.0 (C7)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Alex Rønne Petersen
URL:
: 32993 ()
Depends on:
Blocks:
 
Reported: 2015-06-18 10:41 UTC by denis.zakharov
Modified: 2016-10-04 09:36 UTC (History)
16 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
App crashlog from Xcode (61.04 KB, application/octet-stream)
2015-08-12 04:48 UTC, denis.zakharov
Details
Crash after launching screenshot v 0.20 (263.38 KB, image/png)
2015-08-30 15:29 UTC, denis.zakharov
Details
Crash in Xamarin.Studio 5.10 (build 704) and Xamarin.Profiler 0.21-0(1) (101.85 KB, application/octet-stream)
2015-09-04 06:13 UTC, denis.zakharov
Details
Still crashes (3.79 MB, video/quicktime)
2015-10-09 02:05 UTC, denis.zakharov
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Comment 1 denis.zakharov 2015-06-18 10:46:03 UTC
Using the specification 'ipad,retina,64' and SDK '8.3' the following was selected:
   Runtime: com.apple.CoreSimulator.SimRuntime.iOS-8-3
   DeviceType: com.apple.CoreSimulator.SimDeviceType.iPad-Air
Starting iPad Air
No need to boot (already booted): iPad Air
Installing /Users/exx/Projects/ipad/Latista.iOS/bin/iPhoneSimulator/Debug/Latista.app with Bundle Identifier com.latista.Latista...
Installed 'com.latista.Latista' from /Users/exx/Projects/ipad/Latista.iOS/bin/iPhoneSimulator/Debug/Latista.app
Launching application
Application launched. PID = 18748
Press enter to terminate the application
>
Application Terminated
Comment 2 Rodrigo Moya 2015-06-22 07:00:41 UTC
This looks a lot like the iOS watchdog killing the app, so can you please share the iOS simulator log so that we can confirm it's that?
Comment 3 denis.zakharov 2015-08-12 04:48:46 UTC
Created attachment 12469 [details]
App crashlog from Xcode
Comment 4 Rodrigo Moya 2015-08-12 06:37:01 UTC
Ok, this looks like a crash in the runtime profiler, Kumpera, Alex?
Comment 5 Rodrigo Moya 2015-08-12 06:43:04 UTC
*** Bug 32993 has been marked as a duplicate of this bug. ***
Comment 6 denis.zakharov 2015-08-17 05:41:52 UTC
What kind of info do you need?
Comment 7 Patrick Lind 2015-08-25 14:44:04 UTC
I'm using MvvmCross and I'm attempting to track down a memory issue.  When using Xamarin Profiler the app crashes at startup.  Is this due to iOS killing the app because it takes so long to start with the Profiler attached?  How should I proceed?
Comment 8 Rodrigo Moya 2015-08-27 04:52:49 UTC
Yes, it is due to the wathdog killing the app, but this should be now fixed with the packages in the alpha channel. Please have a try at those and see if they fix the problem for you
Comment 9 Patrick Lind 2015-08-28 09:56:41 UTC
Now I get this error message:

Unsupported MLPD format version (should be <= 10 but is 11)

 Please update to the latest Xamarin Profiler

I believe my profiler is on the latest version:  Version 0.20-0 (1)?
Comment 10 denis.zakharov 2015-08-30 15:27:11 UTC
It still crashes.

Using the specification 'iphone,retina,tall,64' and SDK '8.4' the following was selected:
   Runtime: com.apple.CoreSimulator.SimRuntime.iOS-8-4
   DeviceType: com.apple.CoreSimulator.SimDeviceType.iPhone-5s
Copying in /Users/exx/Projects/ipad/Latista.iOS/bin/iPhoneSimulator/Debug/Latista.app/.monotouch-64
Starting iPhone 5s - iOS 8.4
No need to boot (already booted): iPhone 5s - iOS 8.4
Installing /Users/exx/Projects/ipad/Latista.iOS/bin/iPhoneSimulator/Debug/Latista.app with Bundle Identifier com.latista.Latista...
Installed 'com.latista.Latista' from /Users/exx/Projects/ipad/Latista.iOS/bin/iPhoneSimulator/Debug/Latista.app
Launching application
Application launched. PID = 64598
Press enter to terminate the application
>
Application Terminated
Comment 11 denis.zakharov 2015-08-30 15:29:24 UTC
Created attachment 12688 [details]
Crash after launching screenshot v 0.20
Comment 12 Rodrigo Moya 2015-08-31 04:49:11 UTC
The unsupported MLPD version is fixed in the upcoming release, which will be out this week. About the crash, is this with all the packages updated from the alpha channel?

Also, can you attach the simulator log?
Comment 13 denis.zakharov 2015-09-04 06:12:07 UTC
I updated to alpha. 
Application was launching now for 3 min 30 sec. I started to think that launching process will finish. But it was crashed. So I still couldn’t make any manipulations in application.
Comment 14 denis.zakharov 2015-09-04 06:13:47 UTC
Created attachment 12749 [details]
Crash in Xamarin.Studio 5.10 (build 704) and Xamarin.Profiler 0.21-0(1)
Comment 15 Rodrigo Moya 2015-09-04 08:31:22 UTC
Ok, that crash seems to be in runtime, so Alex/Kumpera, any hint?
Comment 16 Rodrigo Kumpera 2015-09-04 11:06:47 UTC
Hey Alex,

This looks like a profiler crash.
Comment 17 Alex Rønne Petersen 2015-09-04 13:17:56 UTC
Hi,

Does the app crash consistently with a similar crash dump? I.e. this stack trace for the crashed thread:

> ...
> 11  ???                           	000000000000000000 0 + 0
> 12  com.latista.Latista           	0x0000000105287716 mono_profiler_stat_hit + 70
> 13  com.latista.Latista           	0x00000001051d7ee4 sigprof_signal_handler + 292
> 14  libsystem_platform.dylib      	0x000000010de00f1a _sigtramp + 26
> ...

It looks like some sort of startup race condition or initialization order issue. Would be good to know if it's a consistent crash or if it only happens sometimes.

Thanks!
Comment 18 Brandon Minnick 2015-10-08 14:51:36 UTC
Customer confirms that it is no longer an issue
Comment 19 Brandon Minnick 2015-10-08 15:30:34 UTC
Reopening - Closed inadvertently
Comment 20 Ian Leatherbury 2015-10-08 16:02:32 UTC
Hey guys, to clarify, from the CSM on the case: "The customer who reported this is no longer with the company and the replacement does not have further info"
Comment 21 denis.zakharov 2015-10-09 02:05:33 UTC
Created attachment 13252 [details]
Still crashes
Comment 22 denis.zakharov 2015-10-09 02:42:47 UTC
Everytime
Comment 23 Rodrigo Kumpera 2015-10-12 10:55:42 UTC
Hi Denis,

Can you provide the  console output when such crash happens? The video confirms the issue, but it's not possible for us to infer the underlying cause from it.
Comment 24 Alex Rønne Petersen 2016-08-29 15:35:37 UTC
Hi,

The assertion that was causing this crash has since been removed, so the bug should be fixed.
Comment 25 Ludovic 2016-10-04 09:36:32 UTC
Hello,
Since the last update with xocde 8.0 I have the same problem with visual studio. the app close instantly.

Here is the outpout.
Launching 'App1_1.iOS' on 'iPhone 5 iOS 10.0'...
Launch succeeded. The app  'App1_1.iOS' has been successfully launched on 'iPhone 5 iOS 10.0'.
The app has been terminated.

It's happen every time. Where can I go to fix it?

Thanks