Bug 3113 - Context menu's
Summary: Context menu's
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.8.5
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-01-27 11:14 UTC by dj_technohead
Modified: 2012-01-27 18:50 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description dj_technohead 2012-01-27 11:14:56 UTC
Context menu does not appear on second monitor. Dragging MonoDevelop to the primary monitor and then they do appear. 

My configuration is an MBA running OS X 10.7.2 with the second monitor plugged in via the Display Port. I'm running MD 2.8.5.
Comment 1 Mikayla Hutchinson [MSFT] 2012-01-27 14:39:38 UTC
What is your monitor layout?
Comment 3 Jeffrey Stedfast 2012-01-27 16:01:00 UTC
I'm also going to need to know which context menus, because that may make a difference.

Is the MB Air monitor above? below? to the left? or to the right of the thunderbolt display?
Comment 4 dj_technohead 2012-01-27 17:35:07 UTC
The context menus for the solution (left pane).

My external monitor is above the MBA's monitor (from the mini DisplayPort, not Thunderbolt port).
Comment 5 Jeffrey Stedfast 2012-01-27 17:38:11 UTC
thanks
Comment 6 Jeffrey Stedfast 2012-01-27 18:50:29 UTC
I can't reproduce on MonoDevelop 2.8.6.4 (although I did just find/fix a multi-monitor issue for debugger tooltips when MD was on the primary screen in your setup that our CEO mentioned to me a minute ago).

I think this fix that made it into 2.8.6 may have fixed your particular issue:


commit d8fefb1c4dbb84528560090a633875b6dc207e65
Author: Jeffrey Stedfast <jeff@xamarin.com>
Date:   Fri Dec 16 18:46:57 2011 -0500

    [TextEditor] Fixed context-menu placement for vertical multi-monitor setups


(the [TextEditor] bit is misleading, it actually fixes a GtkWorkarounds method to reposition context menus that is shared between the text editor and other areas of MD)

Marking as Fixed, but if you experience this with MonoDevelop 2.8.6.4, reopen and I'll dig into it again.